Bug 1411800 - Error while navigating to Products from the GPG keys page.
Summary: Error while navigating to Products from the GPG keys page.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Credentials
Version: 6.2.6
Hardware: All
OS: Linux
medium
medium
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: jcallaha
URL:
Whiteboard:
Depends On:
Blocks: 1417128
TreeView+ depends on / blocked
 
Reported: 2017-01-10 14:16 UTC by Deepannagaraj Nagarathinam
Modified: 2020-04-15 15:04 UTC (History)
5 users (show)

Fixed In Version: rubygem-katello-3.0.0.97-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1417128 (view as bug list)
Environment:
Last Closed: 2017-03-06 08:36:56 UTC
Target Upstream Version:


Attachments (Terms of Use)
Hotfix patch tarball (3.59 KB, application/x-gzip)
2017-01-26 08:35 UTC, Lukas Zapletal
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 18018 0 None None None 2017-01-10 23:14:49 UTC
Red Hat Knowledge Base (Solution) 2893071 0 None None None 2017-01-30 12:32:35 UTC
Red Hat Product Errata RHBA-2017:0447 0 normal SHIPPED_LIVE Satellite 6.2.8 Async Bug Release 2017-03-06 13:23:41 UTC

Description Deepannagaraj Nagarathinam 2017-01-10 14:16:12 UTC
Description of problem:

- While navigating to Content --> GPG Keys --> <Key_Name> --> Products --> <Product_Name>, hitting the below error.

~~~~~~
Couldn't find product '1481169055753'
~~~~~~

Version-Release number of selected component (if applicable):

- Red Hat Satellite v 6.2.6

How reproducible:

- Always

Steps to Reproduce:

-> Create a Custom Product, Third Party repository and a GPG Key on Satellite server.

-> Associate the Key to the custom product.

-> Then navigate to the product tab on GPG Key page.

Actual results:

- Hitting the below error.

~~~~~~
Couldn't find product '1481169055753'
~~~~~~

Expected results:

- Should redirect to the Product page without any errors.

Additional info:

Comment 4 Brad Buckingham 2017-01-10 23:14:47 UTC
Created redmine issue http://projects.theforeman.org/issues/18018 from this bug

Comment 5 Brad Buckingham 2017-01-10 23:24:25 UTC
Upstream Katello PR: https://github.com/Katello/katello/pull/6533

Comment 6 Lukas Zapletal 2017-01-26 08:35:45 UTC
Created attachment 1244635 [details]
Hotfix patch tarball

Usage (tarball extraction):

  tar -xzf satellite-hotfix-20170101-abcdef1.tar.gz
  cd satellite-hotfix-20170101-abcdef1

Usage (dry run):

  ./satellite-hotfix -n 1234567

Usage:

  ./satellite-hotfix 1234567

Revert a hotfix:

  ./satellite-hotfix -r 1234567

List all avaiable hotfixes:

  ./satellite-hotfix

The numbers are real Red Hat Bugzilla numbers. All backup and reject files are
save in backups/ sub-directory. Please keep the tarball for possible reverting
of the change in the future. If patching fails, revert immediately and report
the output. After each Satellite update, this hotfix process must be repeated
if the updated does not include the bugfix yet, search in errata notes for
bugzilla numbers to confirm.

If system-wide Ruby is not installed for some reason, use Satellite Foreman
Ruby software collection:

  scl enable rh-ruby22 -- ./satellite-hotfix -h

To find out Ruby versions available do:

  ls /opt/*/*ruby* -d

Comment 7 Lukas Zapletal 2017-01-26 15:13:47 UTC
Smallish patch, low risk, low effort (two lines), if you can squeeze it in, thanks!

Comment 8 Oleksandr Shtaier 2017-02-13 10:33:46 UTC
Steps to Reproduce:

-> Create a Custom Product, Third Party repository and a GPG Key on Satellite server.

-> Associate the Key to the custom product.

-> Then navigate to the product tab on GPG Key page.

-> Then click on the product from the list to navigate to products interface

Comment 9 Oleksandr Shtaier 2017-02-13 10:34:41 UTC
Verified on 6.2.8. Functionality works as intended.

We still have same issue in 6.3

Comment 11 errata-xmlrpc 2017-03-06 08:36:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0447


Note You need to log in before you can comment on or make changes to this bug.