Bug 1411827 - Provider TImelines Apply Filter Hangs
Summary: Provider TImelines Apply Filter Hangs
Keywords:
Status: CLOSED DUPLICATE of bug 1388040
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: GA
: cfme-future
Assignee: Heiko W. Rupp
QA Contact: Matt Mahoney
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-10 15:07 UTC by Matt Mahoney
Modified: 2017-01-18 04:53 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-17 16:31:05 UTC
Category: ---
Cloudforms Team: Middleware
Target Upstream Version:


Attachments (Terms of Use)
Timeline Spinner - Hang (68.42 KB, image/png)
2017-01-10 15:07 UTC, Matt Mahoney
no flags Details
EVM.log (248.33 KB, application/zip)
2017-01-10 15:12 UTC, Matt Mahoney
no flags Details

Description Matt Mahoney 2017-01-10 15:07:24 UTC
Created attachment 1239138 [details]
Timeline Spinner - Hang

Description of problem:
When applying filter to Provider Timeline, the wait spinner does not complete.

Version-Release number of selected component (if applicable):
5.7

How reproducible:
Always (Chrome and FF)

Steps to Reproduce:
1. Add Provider to CFME
2. Add and EAP Standalone server to configuration
   EX, start a Docker container: docker run -d -e HAWKULAR_SERVER="http://<hawkular-server>:<hawkular-port>" -e JBOSS_SERVER_MODE=standalone brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/jboss/jboss-eap-7-hawkular-agent:latest
3. Inventory the EAP server in CFME.
4. Navigate to Servers view, and then click on EAP standalone server
5. Add a Deployment to the EAP stanalone server
6. Navigate to Providers view, and then click on the Middleware Provider
7. Click Monitoring, and then Timelines
8. Change filter to "Starting" and then add select "Application" from the dropdown list
9. Click "Apply" and note if the spinner completes OR not.

Actual results:
Timelines filter Apply spinner does not complete (hangs)

Expected results:
Timelines filter should not hang

Additional info:

Comment 2 Matt Mahoney 2017-01-10 15:12:19 UTC
Created attachment 1239140 [details]
EVM.log

Comment 3 Matt Mahoney 2017-01-17 16:31:05 UTC

*** This bug has been marked as a duplicate of bug 1388040 ***


Note You need to log in before you can comment on or make changes to this bug.