Bug 1411828 - qxldod graphical corruption
Summary: qxldod graphical corruption
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virtio-win
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Amnon Ilan
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-10 15:10 UTC by Daniel J Blueman
Modified: 2017-01-30 12:08 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-30 12:08:32 UTC


Attachments (Terms of Use)
Screenshot showing mild graphical corruption (947.08 KB, image/jpeg)
2017-01-10 15:10 UTC, Daniel J Blueman
no flags Details

Description Daniel J Blueman 2017-01-10 15:10:04 UTC
Created attachment 1239139 [details]
Screenshot showing mild graphical corruption

Description of problem:
Mild graphical corruption is seen when moving the mouse cursor, dragging windows or when redrawing sometimes.

Version-Release number of selected component (if applicable):
Using virtio-win-0.1.126.iso

How reproducible:
Always when KVM scales the guest screen to a high-DPI screen, eg on my Dell XPS 15 with 3840x2160.

Steps to Reproduce:
1. Install Windows 10
2. Install qxldod from virtio-win-0.1.126.iso
3. Move mouse cursor, drag windows

Actual results:
Mild graphical corruption seen

Expected results:
No graphical corruption

Additional info:
Screenshot attached showing some corruption around 'operation' from moving the mouse cursor. Most likely, this is an off-by-one or rounding issue.

Comment 1 Amnon Ilan 2017-01-11 09:01:09 UTC
Thanks for taking the time to enter a bug report with us. We use reports like yours to keep improving the quality of our products and releases. That said, we're not able to guarantee the timeliness or suitability of a resolution for issues entered here because this is not a mechanism for requesting support.
                                                                                
If this issue is critical or in any way time sensitive, please raise a ticket through your regular Red Hat support channels to make certain it receives the proper attention and prioritization that will result in a timely resolution.
                                                                                
For information on how to contact the Red Hat production support team, please visit: https://www.redhat.com/support/process/production/#howto

Comment 2 Amnon Ilan 2017-01-30 12:08:32 UTC
Some info on that:

There are two versions of the qxldod driver: the older one is in the ISO, 
coming from https://fedoraproject.org/wiki/Windows_Virtio_Drivers.
The new driver has the upstream version available via spicespace.org at https://www.spice-space.org/download.html

Please try the new version from spice and submit questions/queries to spice-devel list ( see https://www.spice-space.org/contact.html ).

Closing this bug.


Note You need to log in before you can comment on or make changes to this bug.