Bug 1411831 - subselection in access control role, not bubble up in tree display
Summary: subselection in access control role, not bubble up in tree display
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.9.0
Assignee: Dan Clarizio
QA Contact: Kedar Kulkarni
URL:
Whiteboard: ui:widget
: 1428553 1429914 1464271 (view as bug list)
Depends On:
Blocks: 1440405 1461593
TreeView+ depends on / blocked
 
Reported: 2017-01-10 15:23 UTC by Gellert Kis
Modified: 2020-06-11 13:11 UTC (History)
12 users (show)

Fixed In Version: 5.9.0.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1440405 1461593 (view as bug list)
Environment:
cfme 5.7.0.17
Last Closed: 2018-03-06 15:43:47 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description Gellert Kis 2017-01-10 15:23:07 UTC
Description of problem:

Partially selected tree in role access control is not getting invert coloured on top tree item. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Create a new access control role. Save.
2. Edit access control role . Unselect some sub items in tree. Save.  
3. Top tree checkbox colour is not getting inverted.

Actual results:

Top tree checkbox colour is not getting inverted.

Expected results:

Top tree checkbox colour getting inverted.


Additional info:

Comment 6 Harpreet Kataria 2017-03-09 17:35:09 UTC
*** Bug 1428553 has been marked as a duplicate of this bug. ***

Comment 7 Harpreet Kataria 2017-03-09 17:35:33 UTC
*** Bug 1429914 has been marked as a duplicate of this bug. ***

Comment 8 CFME Bot 2017-03-20 14:31:41 UTC
New commit detected on ManageIQ/manageiq/euwe:
https://github.com/ManageIQ/manageiq/commit/e54076bf76cde1a19f7b9539801dae6eaa704abb

commit e54076bf76cde1a19f7b9539801dae6eaa704abb
Author:     Eric Hayes <eric@erichayes.net>
AuthorDate: Wed Jan 18 16:18:40 2017 -0800
Commit:     Eric Hayes <eric@erichayes.net>
CommitDate: Wed Jan 18 17:24:24 2017 -0800

    Build tree by counting all descendants
    
    Currently selected boxes deeper in the tree do not “bubble up” the select state to their ancestors. This changes that by counting all descendants including hidden features, also taking into account 3 possible select states.
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1348623
    https://bugzilla.redhat.com/show_bug.cgi?id=1411831

 app/controllers/ops_controller/rbac_tree.rb       | 319 ++++++++++++++--------
 spec/controllers/ops_controller/rbac_tree_spec.rb |  48 +++-
 2 files changed, 252 insertions(+), 115 deletions(-)

Comment 12 CFME Bot 2017-05-02 11:38:30 UTC
New commit detected on ManageIQ/manageiq-ui-classic/master:
https://github.com/ManageIQ/manageiq-ui-classic/commit/4f46dae639cd83fa3524b8503ea12557544affa1

commit 4f46dae639cd83fa3524b8503ea12557544affa1
Author:     Eric Hayes <eric@erichayes.net>
AuthorDate: Tue Jan 3 13:17:53 2017 -0800
Commit:     Eric Hayes <eric@erichayes.net>
CommitDate: Mon May 1 16:06:10 2017 -0700

    Convert Menu Features Tree to use TreeBuilder
    
    Addresses:
    https://bugzilla.redhat.com/show_bug.cgi?id=1348623
    https://bugzilla.redhat.com/show_bug.cgi?id=1411831
    https://www.pivotaltracker.com/story/show/129518309

 app/controllers/ops_controller/ops_rbac.rb         |  11 +-
 app/controllers/ops_controller/rbac_tree.rb        | 146 ---------------------
 app/presenters/menu/item.rb                        |  10 ++
 app/presenters/menu/manager.rb                     |  12 +-
 app/presenters/menu/section.rb                     |  16 ++-
 app/presenters/tree_builder.rb                     |   8 +-
 app/presenters/tree_builder_ops_rbac_features.rb   | 145 ++++++++++++++++++++
 app/presenters/tree_node/menu/item.rb              |  36 +++++
 app/presenters/tree_node/menu/node.rb              |  28 ++++
 app/presenters/tree_node/menu/section.rb           |  19 +++
 app/presenters/tree_node/miq_product_feature.rb    |  48 +++++++
 app/views/ops/_rbac_role_details.html.haml         | 118 ++++++++---------
 spec/controllers/ops_controller/rbac_tree_spec.rb  |  14 --
 .../tree_builder_ops_rbac_features_spec.rb         |  57 ++++++++
 14 files changed, 431 insertions(+), 237 deletions(-)
 delete mode 100644 app/controllers/ops_controller/rbac_tree.rb
 create mode 100644 app/presenters/tree_builder_ops_rbac_features.rb
 create mode 100644 app/presenters/tree_node/menu/item.rb
 create mode 100644 app/presenters/tree_node/menu/node.rb
 create mode 100644 app/presenters/tree_node/menu/section.rb
 create mode 100644 app/presenters/tree_node/miq_product_feature.rb
 delete mode 100644 spec/controllers/ops_controller/rbac_tree_spec.rb
 create mode 100644 spec/presenters/tree_builder_ops_rbac_features_spec.rb

Comment 13 Eric Hayes 2017-06-14 20:55:43 UTC
This fix cannot be back ported. Targeted fixes for other branches have been submitted.

Comment 15 Harpreet Kataria 2017-07-13 14:48:50 UTC
*** Bug 1464271 has been marked as a duplicate of this bug. ***

Comment 18 Kedar Kulkarni 2017-10-10 18:10:27 UTC
I believe this is fixed. Feel free to comment otherwise, if you still see the issue.


Note You need to log in before you can comment on or make changes to this bug.