Bug 1411902 - [RFE] Provide flexibility to set CPUQuota for slice
Summary: [RFE] Provide flexibility to set CPUQuota for slice
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy
Version: rhgs-3.2
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: RHGS 3.3.1 Async
Assignee: Ramakrishna Reddy Yekulla
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks: 1523617 1581561
TreeView+ depends on / blocked
 
Reported: 2017-01-10 17:24 UTC by SATHEESARAN
Modified: 2018-06-21 03:34 UTC (History)
8 users (show)

Fixed In Version: gdeploy-2.0.2-23
Doc Type: Enhancement
Doc Text:
The CPU Quota is now flexible for the scale functionality. As a result, in a shared workload scenarios the compute resource requirements are shared with the application along with GlusterFS CPU consumption.
Clone Of:
: 1523617 (view as bug list)
Environment:
Last Closed: 2018-06-21 03:33:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:1958 0 None None None 2018-06-21 03:34:47 UTC

Description SATHEESARAN 2017-01-10 17:24:37 UTC
Description of problem:
-----------------------
To create glusterfs slice, slice_setup=yes option could be used 'service' section with 'glusterd' service. But this sets the CPUQuota to the default value of 400%

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
gdeploy-2.0.1-8.el7rhgs

How reproducible:
-----------------
Not Applicable for RFE

Steps to Reproduce:
-------------------
Not Applicable for RFE

Actual results:
----------------
Sets the CPUQuota to the default value of 400% (ie) 4 cores

Expected results:
-----------------
Provide a way to change the CPUQuota and don't hardcode the value of 400%

Comment 5 SATHEESARAN 2018-04-04 02:52:30 UTC
Devyani,

I still don't see any option in 'service' section, that provides the flexibility to add CPUQuota.

Could you please clarify ?

Comment 6 Devyani Kota 2018-04-04 06:31:30 UTC
Hi,
Commit [1] fixes this issue.
It automates the task, by calculating the number of CPU's and then provides the appropriate load.
Ramky can explain more on this.

[1]https://github.com/gluster/gdeploy/pull/493/commits/5d950e6fbc7fdd218284a0f26100c5e995e16eb1

Comment 7 Ramakrishna Reddy Yekulla 2018-04-04 08:54:02 UTC
The way it handles is that, in hyper converged cases where there are other consumers of the CPUload . Its going to allocate 1/3 capacity to the gluster slice. It automated the process for setting up CPUQuota.

Comment 8 SATHEESARAN 2018-04-04 11:24:39 UTC
(In reply to Ramakrishna Reddy Yekulla from comment #7)
> The way it handles is that, in hyper converged cases where there are other
> consumers of the CPUload . Its going to allocate 1/3 capacity to the gluster
> slice. It automated the process for setting up CPUQuota.

Thanks Ramky and Devyani for this information.

Comment 9 SATHEESARAN 2018-04-04 11:34:05 UTC
Tested with gdeploy-2.0.2-24.

By default 1/3 of the CPU is allocated for gluster process.

After running gdeploy with slice setup on the machine with 2 cores.

# cat /etc/systemd/system/glusterfs.slice
[Slice]
CPUQuota=66

Comment 11 Ramakrishna Reddy Yekulla 2018-06-13 09:38:17 UTC
The doc text looks good.

Comment 14 errata-xmlrpc 2018-06-21 03:33:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:1958


Note You need to log in before you can comment on or make changes to this bug.