Bug 1411928 - rhel-registration tooling doesn't distinguish between overcloud node types resulting in subscription overusage
Summary: rhel-registration tooling doesn't distinguish between overcloud node types re...
Keywords:
Status: CLOSED DUPLICATE of bug 1408571
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 10.0 (Newton)
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
: ---
Assignee: Jiri Stransky
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-10 18:59 UTC by Vincent S. Cojot
Modified: 2017-01-11 13:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-11 13:18:51 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Vincent S. Cojot 2017-01-10 18:59:27 UTC
Description of problem:

Looking at the osp10 documentation:
https://access.redhat.com/documentation/en/red-hat-openstack-platform/10/single/director-installation-and-usage/#sect-Repository_Requirements

The basic rhel-registration tooling provided with tripleo-heat-templates only allows a single value for the repos set on -all- overcloud nodes.
See https://github.com/openstack/tripleo-heat-templates/blob/master/extraconfig/pre_deploy/rhel-registration/environment-rhel-registration.yaml#L23

However, overcloud nodes have different requirements. Ceph nodes must consume rhel-7-server-rhceph-2-osd-rpms and rhel-7-server-rhceph-2-mon-rpms repos.

The only way to get those repos to the overcloud ceph nodes is to subscribe -all- overcloud nodes to the ceph repos, resulting in more ceph licences being used. The configuration for repos in rhel-registration in tht should be more fine grained...

Version-Release number of selected component (if applicable):

openstack-tripleo-heat-templates-5.1.0-7.el7ost.noarch

How reproducible:

Comment 1 Mike Burns 2017-01-11 13:18:51 UTC
Duplicate of bug 1408571

Note:  all nodes do need to be subscribed to ceph repos.  Ceph packages exist on all overcloud nodes and need updating there as well.

*** This bug has been marked as a duplicate of bug 1408571 ***


Note You need to log in before you can comment on or make changes to this bug.