Bug 1411938 - upstream test suite fails when full validation is set
Summary: upstream test suite fails when full validation is set
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openscap
Version: 6.8
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: Jan Černý
QA Contact: BaseOS QE Security Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-10 19:20 UTC by Marek Haicman
Modified: 2017-12-06 11:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-06 11:09:25 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Marek Haicman 2017-01-10 19:20:10 UTC
Description of problem:
make check fails on openscap-1.2.13-1.el6 in tests/nist subtest

Version-Release number of selected component (if applicable):
openscap-1.2.13-1.el6 

How reproducible:
reliably

Steps to Reproduce:
1. export OSCAP_FULL_VALIDATION=1 
2. perform make check
3.

Actual results:
================================================
   openscap 1.2.13: tests/nist/test-suite.log
================================================

# TOTAL: 1
# PASS:  0
# SKIP:  0
# XFAIL: 0
# FAIL:  1
# XPASS: 0
# ERROR: 0

.. contents:: :depth: 2

FAIL: nist_test.sh
==================


----------------------------------------------------------------------
+ ind_family_test                                             [ PASS ]
+ ind_unknown_test                                            [ PASS ]
+ ind_variable_test                                           [ PASS ]
+ R500                                                        [ PASS ]
+ R600                                                        [ PASS ]
+ R1100                                                       FAIL nist_test.sh (exit status: 1)

Expected results:
All is passing

Additional info:
Already fixed upstream https://github.com/OpenSCAP/openscap/pull/641

Comment 4 Jan Kurik 2017-12-06 11:09:25 UTC
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/


Note You need to log in before you can comment on or make changes to this bug.