Bug 1411952 - [RFE] [Intel]Collect DMI information and NIC BIOS names
Summary: [RFE] [Intel]Collect DMI information and NIC BIOS names
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic-python-agent
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
low
unspecified
Target Milestone: ga
: 12.0 (Pike)
Assignee: Dmitry Tantsur
QA Contact: mlammon
URL:
Whiteboard:
Depends On:
Blocks: 1389435 1389441
TreeView+ depends on / blocked
 
Reported: 2017-01-10 20:20 UTC by shobha.ranganathan
Modified: 2018-02-05 19:04 UTC (History)
13 users (show)

Fixed In Version: openstack-ironic-python-agent-2.2.1-0.20170925155804.81ac0b4.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-13 21:00:46 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 396406 0 None MERGED Collect NIC name given by BIOS 2020-07-03 01:15:12 UTC
OpenStack gerrit 435573 0 None MERGED Collect processor, memory and BIOS output of dmidecode 2020-07-03 01:15:12 UTC
Red Hat Product Errata RHEA-2017:3462 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description shobha.ranganathan 2017-01-10 20:20:39 UTC
Description of problem: Add support/collectors to discover details of registered nodes like PCI devices, raid, memory etc and store those data in radosgw.


Version-Release number of selected component (if applicable):
https://review.openstack.org/#/c/406790/
https://review.openstack.org/#/c/404372/

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Dmitry Tantsur 2017-04-26 16:22:35 UTC
Hi! I'm updating the subject based on linked patches, as it's not clear what exactly should be introspected otherwise. Thanks!

Comment 2 Ramon Acedo 2017-04-26 18:00:29 UTC
The patches that merged are the specs. Shobha, if there's work upstream started, please add it here for tracking. Targeting Queens for now but can't estimate until the patches  are started. Many thanks.

Comment 5 Dmitry Tantsur 2017-10-02 11:36:03 UTC
Merged back in Pike

Comment 6 Ramon Acedo 2017-11-03 11:47:32 UTC
Hi Shoba, please, once you test this, could you please post here the tests and the results?

Comment 9 Jon Schlueter 2017-12-06 13:26:14 UTC
RH OSP 12 RC contents are up on the RH OSP beta channel. This bug is marked as OtherQA.  If you can take a look at the packages and content and test this bug to see if it is resolved.  It would be much appreciated to get feedback on if this is verified or if there is an issue before we get to GA.

Comment 11 shobha.ranganathan 2017-12-07 15:35:46 UTC
We did some internal testing and here are some steps used.

-	Setup two servers to inspect a baremetal node.
-	Installed the devstack environment with ironic and ironic-inspector.
-	On the devstack server, cloned IPA code (with dmidecode patch). Built the deploy ramdisk and kernel images using TinyIPA. Used these images for inspection by copying them to the httpboot folder. Also, modified the ironic-inspector.ipxe to change the ipa-inspection-callback-url and added dmidecode to ipa-inspection-collectors.
-	Enrolled the baremetal node using:
ironic node-create -n node-3 -d agent_ipmitool -i ipmi_address=<ipmi_addr> -i ipmi_username=<ipmi_username> -i ipmi_password=<ipmi_password>
-	created a port of the <mac address> on server2 listening on dhcp:
ironic --ironic-api-version 1.22 port-create -n <node-3_uuid> -a <mac address>
-	Brought the node to manageable state and inspected using:
ironic node-set-provision-state node-3 manage
ironic node-set-provision-state node-3 inspect
OR
openstack baremetal node manage <NodeID>
openstack baremetal node inspect <NodeID>
-	Checked the inspection data using:
openstack baremetal introspection data save <NodeID>

We cross compared some of the data and found it reporting data correctly.

Comment 12 Bob Fournier 2017-12-07 16:01:20 UTC
Thanks for testing this, marking as VERIFIED.

Comment 15 errata-xmlrpc 2017-12-13 21:00:46 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.