Bug 1411964 - oc get builds panics when sorted on status.startTimestamp
Summary: oc get builds panics when sorted on status.startTimestamp
Keywords:
Status: CLOSED DUPLICATE of bug 1409878
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: oc
Version: 3.3.1
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Fabiano Franz
QA Contact: Xingxing Xia
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-10 20:58 UTC by Avesh Agarwal
Modified: 2017-01-11 01:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-11 01:20:25 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Avesh Agarwal 2017-01-10 20:58:50 UTC
Description of problem:
oc get panics when sorted on status.startTimestamp

Version-Release number of selected component (if applicable):
oc v3.3.1.7
kubernetes v1.3.0+52492b4

How reproducible:
always

Steps to Reproduce:
1. oc get builds --sort-by=.status.startTimestamp
2.
3.

Actual results:
oc get builds --sort-by=.status.startTimestamp
panic: reflect: call of reflect.Value.Interface on zero Value

goroutine 1 [running]:
panic(0x23cb1c0, 0xc82074b920)
	/usr/lib/golang/src/runtime/panic.go:481 +0x3e6
reflect.valueInterface(0x0, 0x0, 0x0, 0x2827701, 0x0, 0x0)
	/usr/lib/golang/src/reflect/value.go:913 +0x7f
reflect.Value.Interface(0x0, 0x0, 0x0, 0x0, 0x0)
	/usr/lib/golang/src/reflect/value.go:908 +0x48
github.com/openshift/origin/vendor/k8s.io/kubernetes/pkg/kubectl.isLess(0x2827720, 0xc82036b880, 0x199, 0x0, 0x0, 0x0, 0x1, 0x0, 0x0)
	/builddir/build/BUILD/atomic-openshift-git-0.0988966/_output/local/go/src/github.com/openshift/origin/vendor/k8s.io/kubernetes/pkg/kubectl/sorting_printer.go:162 +0x8a9
github.com/openshift/origin/vendor/k8s.io/kubernetes/pkg/kubectl.isLess(0x2855140, 0xc821121de0, 0x96, 0x2855140, 0xc821122260, 0x96, 0x0, 0x0, 0x0)
	/builddir/build/BUILD/atomic-openshift-git-0.0988966/_output/local/go/src/github.com/openshift/origin/vendor/k8s.io/kubernetes/pkg/kubectl/sorting_printer.go:157 +0x6ad
github.com/openshift/origin/vendor/k8s.io/kubernetes/pkg/kubectl.(*RuntimeSort).Less(0xc821af90c0, 0x2b4, 0x25e, 0x7f2c843c9400)
	/builddir/build/BUILD/atomic-openshift-git-0.0988966/_output/local/go/src/github.com/openshift/origin/vendor/k8s.io/kubernetes/pkg/kubectl/sorting_printer.go:205 +0x7f1
sort.medianOfThree(0x7f2c84347690, 0xc821af90c0, 0x2b4, 0x25e, 0x208)
	/usr/lib/golang/src/sort/sort.go:81 +0x3f
sort.doPivot(0x7f2c84347690, 0xc821af90c0, 0x0, 0x2b5, 0x4, 0x4)
	/usr/lib/golang/src/sort/sort.go:108 +0x134
sort.quickSort(0x7f2c84347690, 0xc821af90c0, 0x0, 0x2b5, 0x13)
	/usr/lib/golang/src/sort/sort.go:195 +0xa3
sort.Sort(0x7f2c84347690, 0xc821af90c0)
	/usr/lib/golang/src/sort/sort.go:229 +0x74
github.com/openshift/origin/vendor/k8s.io/kubernetes/pkg/kubectl.SortObjects(0x7f2c842bdcf8, 0xc82036b9c0, 0xc82083d000, 0x2b5, 0x2b5, 0xc820741720, 0x16, 0x0, 0x0, 0x0)
	/builddir/build/BUILD/atomic-openshift-git-0.0988966/_output/local/go/src/github.com/openshift/origin/vendor/k8s.io/kubernetes/pkg/kubectl/sorting_printer.go:117 +0x6a0
github.com/openshift/origin/vendor/k8s.io/kubernetes/pkg/kubectl/cmd.RunGet(0xc82009ca00, 0x7f2c8437d1c0, 0xc820026010, 0xc8200b5b00, 0xc8206a4b80, 0x1, 0x2, 0xc82027d020, 0x0, 0x0)
	/builddir/build/BUILD/atomic-openshift-git-0.0988966/_output/local/go/src/github.com/openshift/origin/vendor/k8s.io/kubernetes/pkg/kubectl/cmd/get.go:340 +0x1c6c
github.com/openshift/origin/vendor/k8s.io/kubernetes/pkg/kubectl/cmd.NewCmdGet.func1(0xc8200b5b00, 0xc8206a4b80, 0x1, 0x2)
	/builddir/build/BUILD/atomic-openshift-git-0.0988966/_output/local/go/src/github.com/openshift/origin/vendor/k8s.io/kubernetes/pkg/kubectl/cmd/get.go:94 +0x7d
github.com/openshift/origin/vendor/github.com/spf13/cobra.(*Command).execute(0xc8200b5b00, 0xc8206a4a60, 0x2, 0x2, 0x0, 0x0)
	/builddir/build/BUILD/atomic-openshift-git-0.0988966/_output/local/go/src/github.com/openshift/origin/vendor/github.com/spf13/cobra/command.go:603 +0x896
github.com/openshift/origin/vendor/github.com/spf13/cobra.(*Command).ExecuteC(0xc8202d0000, 0xc8200b5b00, 0x0, 0x0)
	/builddir/build/BUILD/atomic-openshift-git-0.0988966/_output/local/go/src/github.com/openshift/origin/vendor/github.com/spf13/cobra/command.go:689 +0x55c
github.com/openshift/origin/vendor/github.com/spf13/cobra.(*Command).Execute(0xc8202d0000, 0x0, 0x0)
	/builddir/build/BUILD/atomic-openshift-git-0.0988966/_output/local/go/src/github.com/openshift/origin/vendor/github.com/spf13/cobra/command.go:648 +0x2d
main.main()
	/builddir/build/BUILD/atomic-openshift-git-0.0988966/_output/local/go/src/github.com/openshift/origin/cmd/oc/oc.go:29 +0x180

Expected results:
should not panic atleast.

Additional info:

Comment 1 Xingxing Xia 2017-01-11 01:20:25 UTC

*** This bug has been marked as a duplicate of bug 1409878 ***


Note You need to log in before you can comment on or make changes to this bug.