Bug 1412028 - Package exim-clamav postinstall scriptlet creates directory /0750 because of missing option in mkdir command call
Summary: Package exim-clamav postinstall scriptlet creates directory /0750 because of ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: exim
Version: 25
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-11 02:24 UTC by Edgar Hoch
Modified: 2017-09-14 20:20 UTC (History)
2 users (show)

Fixed In Version: exim-4.89-5.fc26 exim-4.89-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-31 14:53:46 UTC
Type: Bug


Attachments (Terms of Use)

Description Edgar Hoch 2017-01-11 02:24:20 UTC
Description of problem:
Package exim-clamav contains in postinstall scriptlet the following line:

/bin/mkdir -p 0750 /var/run/clamd.exim

This creates the directories 0750 (in /, because the working directory is /) and /var/run/clamd.exim .

But I assume there is a syntax error in this command call. I assume "0750" should not be a new directory, but should be interpreted as the file mode of directory /var/run/clamd.exim. There must be a "-m " inserted before "0750". See "man mkdir":

       -m, --mode=MODE
              set file mode (as in chmod), not a=rwx - umask

       -p, --parents
              no error if existing, make parent directories as needed


Version-Release number of selected component (if applicable):
exim-clamav-4.87-5.fc25.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Install a Fedora system without package exim-clamav installed.
2. ls -l /
3. dnf install -y exim-clamav
4. ls -l /

Actual results:
Directory /0750 exists at step 4.

Expected results:
Directory /0750 does not exist at step 4.

Additional info:
I found directory /0750 since many Fedora versions, so this error exists a long time. But I haven't previously found the package that has created this directory.

Comment 1 Jaroslav Škarvada 2017-08-18 14:17:59 UTC
Thanks, nice catch. It seems it was my typo in 2012 :) Unbelievable that it persisted for so long :)

Comment 2 Fedora Update System 2017-08-18 15:21:10 UTC
exim-4.89-5.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2017-f5177f3a16

Comment 3 Fedora Update System 2017-08-18 15:29:32 UTC
exim-4.89-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-a8c25bd6d7

Comment 4 Fedora Update System 2017-08-21 00:19:53 UTC
exim-4.89-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-a8c25bd6d7

Comment 5 Fedora Update System 2017-08-22 18:06:09 UTC
exim-4.89-5.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-f5177f3a16

Comment 6 Fedora Update System 2017-08-31 14:53:46 UTC
exim-4.89-5.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2017-09-14 20:20:08 UTC
exim-4.89-2.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.