Bug 1412056 - The format of error message is inaccurate when no thin pool
Summary: The format of error message is inaccurate when no thin pool
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-node
Classification: oVirt
Component: Installation & Update
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ovirt-4.1.0-rc
: 4.1
Assignee: Douglas Schilling Landgraf
QA Contact: Qin Yuan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-11 05:48 UTC by Qin Yuan
Modified: 2017-02-01 14:52 UTC (History)
13 users (show)

Fixed In Version: imgbased-0.9.3-0.1.el7ev
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-01 14:52:50 UTC
oVirt Team: Node
rule-engine: ovirt-4.1+
cshao: testing_ack+


Attachments (Terms of Use)
/var/log/*, /tmp/* (148.64 KB, application/x-gzip)
2017-01-11 05:48 UTC, Qin Yuan
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 70031 0 master MERGED imgbase: fix error message 2017-01-11 16:41:35 UTC
oVirt gerrit 70052 0 ovirt-4.1 MERGED imgbase: fix error message 2017-01-11 18:39:30 UTC

Description Qin Yuan 2017-01-11 05:48:33 UTC
Created attachment 1239321 [details]
/var/log/*, /tmp/*

Description of problem:
Install RHVH 4.1 and don't select LVM Thin Provisioning when configuring partitions manually,there will be a window popped up to show an error message at the end of installation, as below:

[INFO] Trying to create a manageable base from '/'
[ERROR] LVM Thin Provisioning partitioning scheme is required.
For autoinstall via Kickstart with LVM Thin Provisioning check options: --thinpool and --growPlease consult documentation for details

The words "--grow" and "Please" are put together without any separator. It's better to put a dot or an enter between them.


Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.1-0.20170104.0
imgbased-0.9.2-0.1.el7ev.noarch


How reproducible:
100%


Steps to Reproduce:
1. Install redhat-virtualization-host-4.1-20170104.0
2. Enter MANUAL PARTITIONING page via choosing "I will configure partitioning" in the INSTALLATION DESTINATION page.
3. Select partitioning scheme as LVM, not LVM Thin Provisioning
4. Click "Click here to create them automatically"
5. Finish the remained steps and wait to see the error window popping up.

Actual results:
1. After step5, An error window popped up shows the inaccurate message described above.

Expected results:
1. After step5, An error window popped up shows correct message.

Additional info:

Comment 1 Red Hat Bugzilla Rules Engine 2017-01-11 13:04:07 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 2 Red Hat Bugzilla Rules Engine 2017-01-11 17:26:19 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 3 Qin Yuan 2017-01-18 10:11:40 UTC
Test Versions:
redhat-virtualization-host-4.1-20170116.0
imgbased-0.9.4-0.1.el7ev.noarch

Test Steps:
The same as steps described in the Bug's Description.(The version should be the new one)

Test Results:
There is a window popped up to show an error message at the end of installation, as below:

[INFO] Trying to create a manageable base from '/'
[ERROR] LVM Thin Provisioning partitioning scheme is required.
For autoinstall via Kickstart with LVM Thin Provisioning check options: --thinpool and --grow. Please consult documentation for details


The messages don't have the problem described in the bug's Description. So modify the bug's status to VERIFIED.


Note You need to log in before you can comment on or make changes to this bug.