Bug 1412067 - [virtio-win][whql][netkvm] job 1c_IOCTLCoverage failed.
Summary: [virtio-win][whql][netkvm] job 1c_IOCTLCoverage failed.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.4
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: ybendito
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-11 06:44 UTC by xiagao
Modified: 2017-08-01 12:55 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 12:55:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
job log (19.33 MB, application/zip)
2017-01-11 06:44 UTC, xiagao
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2341 0 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2017-08-01 16:52:38 UTC

Description xiagao 2017-01-11 06:44:40 UTC
Created attachment 1239335 [details]
job log

Description of problem:
job 1c_IOCTLCoverage failed on win10-32/64 and win2016


Version-Release number of selected component (if applicable):
virtio-win-prewhql-129
qemu-kvm-rhev-2.6.0-29.el7.x86_64
kernel-3.10.0-537.el7.x86_64
seabios-1.9.1-5.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.boot guest with netkvm driver
 /usr/libexec/qemu-kvm -name 129NICW10D64CZH -enable-kvm -m 3G -smp 4 -uuid 2bb32e1f-64ba-46ba-8432-c86dbb3011b2 -nodefconfig -nodefaults -chardev socket,id=charmonitor,path=/tmp/129NICW10D64CZH,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=localtime,driftfix=slew -boot order=cd,menu=on -device piix3-usb-uhci,id=usb -drive file=129NICW10D64CZH,if=none,id=drive-ide0-0-0,format=raw,serial=mike_cao,cache=none -device ide-drive,bus=ide.0,unit=0,drive=drive-ide0-0-0,id=ide0-0-0 -drive file=en_windows_10_enterprise_version_1607_updated_jul_2016_x64_dvd_9054264.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -drive file=129NICW10D64CZH.vfd,if=floppy,id=drive-fdc0-0-0,format=raw,cache=none -netdev tap,script=/etc/qemu-ifup1,downscript=no,id=hostnet0 -device e1000,netdev=hostnet0,id=net0,mac=00:52:61:32:28:dc -chardev pty,id=charserial0 -device isa-serial,chardev=charserial0,id=isa_serial0 -device usb-tablet,id=input0 -vnc 0.0.0.0:2 -vga cirrus -M pc -netdev tap,script=/etc/qemu-ifup-private,downscript=no,id=hostnet1,vhost=on,queues=4 -device virtio-net-pci,netdev=hostnet1,id=net1,mac=00:52:60:24:42:bf,bus=pci.0,mq=on,vectors=10

2.submit jobs
3.

Actual results:
Failed with error info: Unable to query OID

Expected results:
pass

Additional info:
1.this job failed on win2016,win8.1-32/64,win2012 and win2012r2.
2.test it on win10-32 with virtio-win-prewhql-128, result is pass.
3.attach is all the job log.

Comment 1 Peixiu Hou 2017-01-11 07:12:20 UTC
Also hit the same issue on win2008R2, win7-32/64, win8-32/64.

Comment 2 xiagao 2017-01-16 07:33:32 UTC
verified this bug on virtio-win-prewhql-130

guest: win10-32

virtio-win-prewhql-130
qemu-kvm-rhev-2.6.0-29.el7.x86_64
kernel-3.10.0-537.el7.x86_64
seabios-1.9.1-5.el7.x86_64

Comment 5 errata-xmlrpc 2017-08-01 12:55:38 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2341


Note You need to log in before you can comment on or make changes to this bug.