Bug 1412073 - The web UI seems no react after clicking the host which failed to register under host tab on ovirt-engine4.1
Summary: The web UI seems no react after clicking the host which failed to register un...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: General
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: ovirt-4.1.0-rc
: ---
Assignee: Alexander Wels
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-11 07:23 UTC by dguo
Modified: 2017-01-23 08:17 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-23 08:17:11 UTC
oVirt Team: UX
rule-engine: ovirt-4.1+


Attachments (Terms of Use)
engine/ vdsm log (728.62 KB, application/x-gzip)
2017-01-11 07:23 UTC, dguo
no flags Details
UI log (41.36 KB, text/plain)
2017-01-13 05:01 UTC, dguo
no flags Details

Description dguo 2017-01-11 07:23:12 UTC
Created attachment 1239342 [details]
engine/ vdsm log

Description of problem:
The web UI seems hang or no react after clicking the host which failed to register under host tab in the ovirt-engine4.1

Version-Release number of selected component (if applicable):
ovirt engine version:4.1.0-0.1-beta1.20161201090635.el7.centos
redhat-virtualization-host-4.1-20170104.0.x86_64
imgbased-0.9.2-0.1.el7ev.noarch
vdsm-4.19.1-1.el7ev.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Register a new installed rhvh4.1
2. The rhvh were failed to register and need to change to maintenance state
3. Click the above rhvh

Actual results:
1.After step#3, the web ui seems no react and can not continue
2.From engine.log, can catch following error: 
"[org.ovirt.engine.core.vdsbroker.vdsbroker.GetAllVmStatsVDSCommand] (DefaultQuartzScheduler4) [] Command 'GetAllVmStatsVDSCommand(HostName = dguo_fc, VdsIdVDSCommandParametersBase:{runAsync='true', hostId='4d1de5b4-c9e7-4cdc-85c2-8e365eb09ed7'})' execution failed: VDSGenericException: VDSNetworkException: Message timeout which can be caused by communication issues"


Expected results:
1. After step#3, the specified host could be chosen, and could be clicked to change to Maintenance state

Additional info:
1. No such issue when click a successful registration rhvh4.1 
2. No such issue on rhvm4.0

Comment 1 Tomas Jelinek 2017-01-12 07:09:24 UTC
This points more to an UI exception rather than engine one. Please install the webadmin-debuginfo package (please make sure in the same version as the webadmin itself), restart the engine and reproduce again and attach the /var/log/ovirt-engine/ui.log

Comment 2 dguo 2017-01-13 05:01:56 UTC
Created attachment 1240205 [details]
UI log

Comment 3 dguo 2017-01-13 05:03:18 UTC
According to the comment1, installed webadmin-debuginfo package

[root@rhvm41-vlan50-beta ~]# rpm -qa|grep debug
ovirt-engine-webadmin-portal-debuginfo-4.1.0-0.1.beta1.20161201090635.el7.centos.noarch
ovirt-engine-userportal-debuginfo-4.1.0-0.1.beta1.20161201090635.el7.centos.noarch

Reproduced and attach the UI log

Comment 4 Tomas Jelinek 2017-01-16 12:50:45 UTC
In logs I see:
"$wnd.jQuery is not a function"
which seems to be the reason why the UI stops reacting.
Moving to UX for more investigation.

Comment 5 Oved Ourfali 2017-01-16 13:03:03 UTC
Alexander, can you take a look?

Comment 6 Alexander Wels 2017-01-16 14:41:41 UTC
Sure,

The message seems to indicate that jQuery is no longer available, which is obviously really bad. To the report does the following 'fix' the issue:

When the UI is unresponsive, and you reload the UI (press the refresh button in the browser), does the UI start working again?

Comment 7 dguo 2017-01-23 08:12:44 UTC
Indeed (In reply to Alexander Wels from comment #6)
> Sure,
> 
> The message seems to indicate that jQuery is no longer available, which is
> obviously really bad. To the report does the following 'fix' the issue:
> 
> When the UI is unresponsive, and you reload the UI (press the refresh button
> in the browser), does the UI start working again?

Yes, after reload, the ui can start work again.

I had to say above issue can be only found in that build 4.1.0-0.1-beta1.20161201090635.el7.centos, when I upgrade to rhv-4.1.0-3 or later, never reproduced it.

Comment 8 Oved Ourfali 2017-01-23 08:17:11 UTC
So if it doesn't reproduce afterwards, I close it as worksforme.


Note You need to log in before you can comment on or make changes to this bug.