Bug 1412094 - The format of error message is inaccurate when using imgbase layout --init after installation finished
Summary: The format of error message is inaccurate when using imgbase layout --init af...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-node
Classification: oVirt
Component: General
Version: 4.1
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ovirt-4.1.0-rc
: 4.1
Assignee: Douglas Schilling Landgraf
QA Contact: Qin Yuan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-11 09:07 UTC by Qin Yuan
Modified: 2017-02-01 14:34 UTC (History)
13 users (show)

Fixed In Version: imgbased-0.9.3-0.1.el7ev
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-01 14:34:31 UTC
oVirt Team: Node
rule-engine: ovirt-4.1+
cshao: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 70030 0 master MERGED imgbase: add space in the message 2017-01-11 16:41:19 UTC
oVirt gerrit 70040 0 ovirt-4.1 MERGED imgbase: add space in the message 2017-01-11 18:39:15 UTC

Description Qin Yuan 2017-01-11 09:07:40 UTC
Description of problem:
Install RHVH 4.1, after reboot and log in to RHVH system, run command "imgbase layout --init", there will be an error message printed out as below:

imgbased.imgbase.ExistingImgbaseWithTags: Looks like the system already has imgbase working properly.
However, imgbase was called with --init. If this wasintentional, please untag the existing volumes and try again.

The words "was" and "intentional" are connected together without any separator. There should be a space between them.


Version-Release number of selected component (if applicable):
redhat-virtualization-host-4.1-0.20170104.0
imgbased-0.9.2-0.1.el7ev.noarch


How reproducible:
100%


Steps to Reproduce:
1. Install redhat-virtualization-host-4.1-0.20170104.0
2. Reboot and log in to RHVH 4.1
3. Run "imgbase layout --init"

Actual results:
1. After step3, An inaccurate error message as described above is printed out on the screen.

Expected results:
1. After step3, An accurate error message will be printed out on the screen.

Additional info:

Comment 1 Red Hat Bugzilla Rules Engine 2017-01-11 17:26:02 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 2 Qin Yuan 2017-01-18 09:38:40 UTC
Test Versions:
redhat-virtualization-host-4.1-20170116.0
imgbased-0.9.4-0.1.el7ev.noarch

Test Steps:
1. Install redhat-virtualization-host-4.1-20170116.0
2. Reboot and log in to RHVH 4.1
3. Run "imgbase layout --init"

Test Results:
After step3, there are error messages as below:
imgbased.imgbase.ExistingImgbaseWithTags: Looks like the system already has imgbase working properly.
However, imgbase was called with --init. If this was intentional, please untag the existing volumes and try again.

The messages don't have the problem described in the bug's Description. So modify the bug's status to VERIFIED.


Note You need to log in before you can comment on or make changes to this bug.