Bug 1412137 - Upgrading dnf makes dnf fail
Summary: Upgrading dnf makes dnf fail
Keywords:
Status: CLOSED DUPLICATE of bug 1409557
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-11 10:53 UTC by Jan Pazdziora
Modified: 2017-01-11 12:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-11 11:23:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Jan Pazdziora 2017-01-11 10:53:53 UTC
Description of problem:

When dnf gets upgraded on rawhide, either directly or as a dependency, subsequent dnf invocations fail with

/usr/libexec/system-python: relocation error: /lib64/libpython3.6m.so.1.0: symbol getrandom, version GLIBC_2.25 not defined in file libc.so.6 with link time reference

Version-Release number of selected component (if applicable):

dnf-2.0.0-0.rc1.4.fc26.noarch -> dnf-2.0.0-2.fc26.noarch

How reproducible:

Deterministic.

Steps to Reproduce:
1. docker run --rm -ti fedora:rawhide bash
2. In the container: dnf upgrade -y dnf
   Or something like dnf install -y rpm-build which for some reason upgrades dnf as well.
3. In the container: dnf list

Actual results:

/usr/libexec/system-python: relocation error: /lib64/libpython3.6m.so.1.0: symbol getrandom, version GLIBC_2.25 not defined in file libc.so.6 with link time reference

Expected results:

No error.

Additional info:

Comment 1 Igor Gnatenko 2017-01-11 11:23:53 UTC

*** This bug has been marked as a duplicate of bug 1409557 ***

Comment 2 Lukas Slebodnik 2017-01-11 11:44:38 UTC
If you check related discussion on fedora-devel[1] you will find out that there is not a solution for this bug. They do not even want to rebuild docker images to prevent such bugs :-(

[1] https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/B565A2TWWZILEJRI6BFEVNMI6PLGXGO5/

Comment 3 Jan Pazdziora 2017-01-11 12:23:46 UTC
Yes, it's a sad world we live in. I think computers are just hard.


Note You need to log in before you can comment on or make changes to this bug.