Bug 1412138 - remote-viewer doesn't show progress bar for drag-and-drop copying.
Summary: remote-viewer doesn't show progress bar for drag-and-drop copying.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Victor Toso
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-11 11:09 UTC by Andrei Stepanov
Modified: 2017-08-01 15:06 UTC (History)
10 users (show)

Fixed In Version: virt-viewer-5.0-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 15:06:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1849 0 normal SHIPPED_LIVE virt-viewer bug fix and enhancement update 2017-08-01 17:49:46 UTC

Description Andrei Stepanov 2017-01-11 11:09:56 UTC
remote-viewer stops showing a progress bar for DnD copying after previous cancel.

virt-viewer-2.0-12.el7.x86_64 (client)
spice-vdagent-0.14.0-12.el6.x86_64/i686 (guest)

1. Open a connection to a VM with remote-viewer.
2. On client create two big files ~ 300MiB(or bigger) each.
3. Select and Drag-and-drop two files from the client to the guest.
4. Progress bar appears.
5. While files are being copied press "Cancel".

For any next DnD action there will be not shown progress bar.

Comment 2 Victor Toso 2017-01-11 15:13:36 UTC
(In reply to Andrei Stepanov from comment #0)
> For any next DnD action there will be not shown progress bar.

Yes, weird. I can see that the window was created but I can't really see it. I'll investigate. Thanks!

Comment 3 Victor Toso 2017-04-19 13:54:41 UTC
Andrei, could you check this bug once again now that we did the rebase?
I tried here with packages bellow and I was not able to reproduce so far.

virt-viewer-5.0-2.el7.x86_64
spice-gtk3-0.33-3.el7.x86_64
spice-glib-0.33-3.el7.x86_64

Comment 4 Andrei Stepanov 2017-05-04 08:14:48 UTC
Verified with:

Client:
spice-protocol-0.12.12-2.el7.noarch
spice-glib-0.33-3.el7.x86_64
spice-gtk3-vala-0.33-3.el7.x86_64
spice-gtk-tools-0.33-3.el7.x86_64
spice-glib-devel-0.33-3.el7.x86_64
spice-gtk3-0.33-3.el7.x86_64
virt-viewer-5.0-2.el7.x86_64

Guest:
spice-vdagent-0.14.0-14.el7.x86_64

Cannot reproduce the original bug report.

Comment 5 errata-xmlrpc 2017-08-01 15:06:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1849


Note You need to log in before you can comment on or make changes to this bug.