Bug 1412151 - [RFE] Allow setting constraints for manual partitioning
Summary: [RFE] Allow setting constraints for manual partitioning
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Vendula Poncova
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-11 12:02 UTC by Fabian Deutsch
Modified: 2017-08-01 08:53 UTC (History)
12 users (show)

Fixed In Version: anaconda-21.48.22.100-1
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 08:53:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1380767 None CLOSED [RFE] anaconda should support setting the default partitioning type as part of an installclass 2019-07-15 17:47:18 UTC
Red Hat Product Errata RHBA-2017:2293 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2017-08-01 12:39:44 UTC

Internal Links: 1380767

Description Fabian Deutsch 2017-01-11 12:02:33 UTC
Description of problem:
For RHVH we are using a custom installclass to set the autopartitioning, this works fine.

But as soon as the user chooses manul partitioning, he is completely free in doing the partitioning. The issue is that RHVH has a few (4?) constraints like
- Needs to be thin LV for /
- /boot must be >=1GB
- /var must be on a separate LV or partition
- /var must be at least 10GB

We would like to have a way to express these constraints from the installclass.

Version-Release number of selected component (if applicable):
7.3

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Vendula Poncova 2017-03-01 11:01:32 UTC
A pull request with a fix is available here: https://github.com/rhinstaller/anaconda/pull/972

One of the commits adds required constraints to the class OvirtBaseInstallClass. Is it all right or do you use your own install class?

Comment 2 Ryan Barry 2017-03-01 13:05:52 UTC
That's the installclass we use, and the changes look good, so +1 from me.

Comment 4 Peter Kotvan 2017-06-01 07:51:31 UTC
The patch is present in anaconda anaconda-21.48.22.115-1.el7. Moving to VERIFIED (SanityOnly).

Comment 5 errata-xmlrpc 2017-08-01 08:53:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2293


Note You need to log in before you can comment on or make changes to this bug.