Bug 1412159 - [RFE] Add directive to set the installclass from kickstart
Summary: [RFE] Add directive to set the installclass from kickstart
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 1481162
TreeView+ depends on / blocked
 
Reported: 2017-01-11 12:14 UTC by Fabian Deutsch
Modified: 2018-04-10 08:47 UTC (History)
10 users (show)

Fixed In Version: anaconda-21.48.22.123-1
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1481162 (view as bug list)
Environment:
Last Closed: 2018-04-10 08:45:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0671 None None None 2018-04-10 08:47:04 UTC

Description Fabian Deutsch 2017-01-11 12:14:32 UTC
Description of problem:
Currently installclasses have some logic to decide if they should be used or not.

Sometimes however it makes sense of the installclass (which contains product specific configurations like branding and autopartitioning layout) can be set within the kickstart.

If this feature was a avilable, and the stock RHEL installation iso contained the product images of additional products, then the same ISO could be used to install multiple products.

This is currently not possible i.e. when the RHEL installer shall be used to install RHVH using PXE (because in that case the buildstamp file is not available).

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Vendula Poncova 2017-08-14 13:10:54 UTC
Fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/1148

Comment 3 Vendula Poncova 2017-08-29 12:44:35 UTC
The command installclass can be defined in the %anaconda section now.

Comment 5 Peter Kotvan 2017-12-11 11:08:13 UTC
It's not possible to verify this directly since we don't have such isos as mentioned in the bug description. However the changes are present in anaconda-21.48.22.128-1.el7. Moving to verified, sanityonly.

Comment 8 errata-xmlrpc 2018-04-10 08:45:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0671


Note You need to log in before you can comment on or make changes to this bug.