Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1412162 - The utility dig has incorrectly formatted manual page
Summary: The utility dig has incorrectly formatted manual page
Keywords:
Status: CLOSED DUPLICATE of bug 1397186
Alias: None
Product: Fedora
Classification: Fedora
Component: bind
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Menšík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-11 12:21 UTC by Lukas Slebodnik
Modified: 2017-01-16 11:14 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-16 11:14:32 UTC
Type: Bug


Attachments (Terms of Use)

Description Lukas Slebodnik 2017-01-11 12:21:29 UTC
Description of problem:
The utility dig has incorrectly formatted manual page 

Version-Release number of selected component (if applicable):
sh$ rpm -q man-db bind-utils
man-db-2.7.5-3.fc25.x86_64
bind-utils-9.10.4-2.P4.fc25.x86_64

How reproducible:
Deterministic

Steps to Reproduce:
1. man dig

Actual results:
DIG(1)                               BIND9                              DIG(1)

  .SH "NAME" dig - DNS lookup utility
  .SH "SYNOPSIS"
    .HP 4
      dig
       [@server]
       [-b address]
       [-c class]
       [-f filename]
       [-k filename]
       [-m]
       [-p port#]
       [-q name]
       [-t type]
       [-v]
       [-x addr]
       [-y [hmac:]name:key]
       [-4]
       [-6]
       [name]
       [type]
       [class]
       [queryopt...]
    .HP 4
      dig
       [-h]


Expected results:
DIG(1)                               BIND9                              DIG(1)

NAME
       dig - DNS lookup utility

SYNOPSIS
       dig [@server] [-b address] [-c class] [-f filename] [-k filename] [-m]
           [-p port#] [-q name] [-t type] [-v] [-x addr] [-y [hmac:]name:key]
           [-4] [-6] [name] [type] [class] [queryopt...]

       dig [-h]

       dig [global-queryopt...] [query...]

DESCRIPTION
       dig (domain information groper) is a flexible tool for interrogating
       DNS name servers. It performs DNS lookups and displays the answers that
       are returned from the name server(s) that were queried. Most DNS
       administrators use dig to troubleshoot DNS problems because of its
       flexibility, ease of use and clarity of output. Other lookup tools tend
       to have less functionality than dig.

       Although dig is normally used with command-line arguments, it also has
       a batch mode of operation for reading lookup requests from a file. A
       brief summary of its command-line arguments and options is printed when
       the -h option is given. Unlike earlier versions, the BIND 9
       implementation of dig allows multiple lookups to be issued from the


Additional info:
The manual page for nslookup looks good

Comment 1 Petr Menšík 2017-01-16 11:14:32 UTC

*** This bug has been marked as a duplicate of bug 1397186 ***


Note You need to log in before you can comment on or make changes to this bug.