Bug 1412173 - /usr/lib/systemd/system/microcode.service is botched
Summary: /usr/lib/systemd/system/microcode.service is botched
Keywords:
Status: CLOSED DUPLICATE of bug 1411232
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: microcode_ctl
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Petr Oros
QA Contact: Rachel Sibley
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-11 12:55 UTC by Andrew J. Schorr
Modified: 2017-01-12 18:14 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-11 13:11:48 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Andrew J. Schorr 2017-01-11 12:55:33 UTC
Description of problem:
after updating to the new version of microcode_ctl, systemd complains with these error messages:

Jan 10 22:05:09 ti139 systemd[1]: [/usr/lib/systemd/system/microcode.service:10] Trailing garbage, ignoring.
Jan 10 22:05:09 ti139 systemd[1]: microcode.service lacks both ExecStart= and ExecStop= setting. Refusing.



Version-Release number of selected component (if applicable):
microcode_ctl-2.1-16.1.el7_3.x86_64

How reproducible:
Update the rpm and wait for systemd to complain.

Steps to Reproduce:
1. update the rpm 
2. wait for systemd to complain
3.

Actual results:
The ExecStart command has botched quoting. It says:


ExecStart=/usr/bin/bash -c "grep -l GenuineIntel /proc/cpuinfo | xargs grep -l "model.*79" > /dev/null || echo 1 > /sys/devices/system/cpu/microcode/reload"

There should be single quotes around it, not double quotes, like so:

ExecStart=/usr/bin/bash -c 'grep -l GenuineIntel /proc/cpuinfo | xargs grep -l "model.*79" > /dev/null || echo 1 > /sys/devices/system/cpu/microcode/reload'



Expected results:


Additional info:

Comment 1 Petr Oros 2017-01-11 13:11:48 UTC

*** This bug has been marked as a duplicate of bug 1411232 ***


Note You need to log in before you can comment on or make changes to this bug.