Bug 1412181 - [RFE] nfs4_getfacl should accept more paths
Summary: [RFE] nfs4_getfacl should accept more paths
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs4-acl-tools
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: Yongcheng Yang
URL:
Whiteboard:
Depends On:
Blocks: 1698080
TreeView+ depends on / blocked
 
Reported: 2017-01-11 13:18 UTC by Ondrej
Modified: 2019-04-09 15:02 UTC (History)
4 users (show)

Fixed In Version: nfs4-acl-tools-0.3.3-18.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1698080 (view as bug list)
Environment:
Last Closed: 2018-10-30 11:43:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3291 0 None None None 2018-10-30 11:43:11 UTC

Description Ondrej 2017-01-11 13:18:35 UTC
Description of problem:
Currently, nfs4_getfacl only accept a single path. Whereas it is OK in most cases, as there is currently no support for nfsv4 acls in glibc, we have no way of knowing (ls -l won't tell us) which file/directory is using acls.
This would be a workaround.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 Yongcheng Yang 2018-06-25 03:24:17 UTC
Updating the summary adding "RFE" (Request for enhancement) keyword.
Please correct me if it's not correct.

Comment 7 Yongcheng Yang 2018-07-06 05:48:40 UTC
Have checked nfs4_getfacl can accept more than one path now with nfs4-acl-tools-0.3.3-18.el7

Moving this to VERIFIED and will include this case as regression tests.

~~~~~~~~~~~~~
Testing logs:
~~~~~~~~~~~~~
[root@ ~]# cat /proc/mounts | grep mnt
localhost:/export_test /mnt/1 nfs4 rw,relatime,vers=4.1,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp6,port=0,timeo=600,retrans=2,sec=sys,clientaddr=::1,local_lock=none,addr=::1 0 0
localhost:/export_test2 /mnt/2 nfs4 rw,relatime,vers=4.1,rsize=1048576,wsize=1048576,namlen=255,hard,proto=tcp6,port=0,timeo=600,retrans=2,sec=sys,clientaddr=::1,local_lock=none,addr=::1 0 0
[root@ ~]# rpm -q nfs4-acl-tools
nfs4-acl-tools-0.3.3-18.el7.x86_64
[root@ ~]# 
[root@ ~]# nfs4_getfacl /mnt /mnt/1 /mnt/1/testfile /mnt/2
Operation to request attribute not supported.

# file: /mnt/1       <<<<<<<<<<<<<
A::OWNER@:rwaDxtTcCy
A::GROUP@:rxtcy
A::EVERYONE@:rxtcy

# file: /mnt/1/testfile  <<<<<<<<
A::OWNER@:rwatTcCy
A::GROUP@:rtcy
A::EVERYONE@:rtcy

# file: /mnt/2           <<<<<<<<
A::OWNER@:rwaDxtTcCy
A::GROUP@:rxtcy
A::EVERYONE@:rxtcy
[root@ ~]# 
[root@ ~]# echo $?
0
[root@ ~]#

Comment 11 errata-xmlrpc 2018-10-30 11:43:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3291


Note You need to log in before you can comment on or make changes to this bug.