Bug 1412202 - config_tempest does not have the capability to discover and configure manila/share section under tempest.conf
Summary: config_tempest does not have the capability to discover and configure manila/...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tempest
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Dustin Schoenbrun
QA Contact: tkammer
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-11 14:16 UTC by Anshul Behl
Modified: 2017-07-17 15:38 UTC (History)
7 users (show)

Fixed In Version: openstack-tempest-13.0.0-12.bafe630git.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-07-17 15:38:35 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Gerrithub.io 344522 0 None None None 2017-03-21 08:36:56 UTC
OpenStack gerrit 419440 0 None None None 2017-01-13 11:19:10 UTC

Description Anshul Behl 2017-01-11 14:16:43 UTC
Description of problem:

File config_tempest.py does not have the capability to discover manila and then configure tempest.conf accordingly.


Version-Release number of selected component (if applicable):
openstack-tempest-13.0.0-7.bafe630git.el7ost.noarch
puppet-tempest-9.4.0-1.el7ost.noarch
python-tempest-13.0.0-7.bafe630git.el7ost.noarch


How reproducible:
Everytime


Steps to Reproduce:
SERVICE_NAMES = {
    'baremetal': 'ironic',
    'compute': 'nova',
    'database': 'trove',
    'data-processing': 'sahara',
    'image': 'glance',
    'network': 'neutron',
    'object-store': 'swift',
    'orchestration': 'heat',
    'telemetry': 'ceilometer',
    'volume': 'cinder',
    'messaging': 'zaqar',
}

Above section under the file does not configure manila because there is no similar key present, in addition to this it also need to discover the resources/protocols enabled so that tempest manila tests don't skip.

Actual results:
Manila tempest tests skip if file generated using config_tempest.py

Expected results:
Manila tempest tests should not skip

Additional info:

Comment 1 Anshul Behl 2017-01-23 10:11:38 UTC
Hi Dustin,

Will it be possible to backport this patch to RHOS 10, because currently manila partners will be affected by this bug and we are expecting Netapp to certify soon.

Thanks,
Anshul Behl

Comment 2 Dustin Schoenbrun 2017-01-23 19:53:20 UTC
Hey Anshul,

It will be very easy to backport this to the OSP-10 branch. I do think that, however, we need to set the expectation that there will still be a sizeable amount of manual intervention required to correctly configure not only Manila but also other services like Cinder. I will update this space when the backport has merged.


Note You need to log in before you can comment on or make changes to this bug.