Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1412213 - Unable to get the host/guest details using curl
Summary: Unable to get the host/guest details using curl
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin
Version: 2.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ---
: 2.0
Assignee: William Poteat
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-11 14:32 UTC by Rehana
Modified: 2017-03-27 14:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-27 14:03:45 UTC


Attachments (Terms of Use)
candlepin.logs (16.02 MB, application/x-bzip)
2017-01-12 17:35 UTC, Rehana
no flags Details
access.logs (6.16 MB, application/x-bzip)
2017-01-12 17:37 UTC, Rehana
no flags Details

Description Rehana 2017-01-11 14:32:51 UTC
Description of problem:


Version-Release number of selected component (if applicable):
subscription management server: 2.0.21-1
subscription management rules: 5.20
subscription-manager: 1.18.6-1.el6
python-rhsm: 1.18.6-1.el6


How reproducible:
not always

Steps to Reproduce:
1.Register host to candlepin
2.Register client machine to candlepin 
3.Restart virt-who on host
4. try to get the host/guest details using curl

Actual results:
client identity:
# subscription-manager identity
system identity: e927ead0-b628-45a1-9228-6b542e6f6f74
name: dhcp187-132.khw.lab.eng.bos.redhat.com
org name: Admin Owner
org ID: admin

# curl -k -u admin:admin https://F21-candlepin.usersys.redhat.com:8443/candlepin/consumers/e927ead0-b628-45a1-9228-6b542e6f6f74/host | python -mjson.tool
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:--  0:00:01 --:--:--     0
No JSON object could be decoded


[root@hp-z230-02 facts]# curl -k -u admin:admin https://F21-candlepin.usersys.redhat.com:8443/candlepin/consumers/6b900040-2c3e-4527-8ec6-6d8140e1ffb4/guests | python -mjson.tool
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     3    0     3    0     0      2      0 --:--:--  0:00:01 --:--:--     7
[]

Expected results:
should list the host/guest details 

Additional info:
rhsm.log
========
2017-01-11 09:32:28,120 [INFO] @subscriptionmanager.py:153 - Sending update in guests lists for config "env/cmdline": 1 guests found
2017-01-11 09:32:31,325 [ERROR] @executor.py:161 - Error in communication with subscription manager:
RestlibException: Problem updating unit Consumer [id: null, uuid: e894533a-1630-46c3-a229-2c16713b446d, consumerType: null, name: null] -- org.candlepin.model.Consumer@6456261f


access.log
===========10.16.187.132 - - [11/Jan/2017:19:50:44 +0530] "GET /candlepin/consumers/e927ead0-b628-45a1-9228-6b542e6f6f74/host HTTP/1.1" 204 - "" "curl/7.19.7 (x86_64-redhat-linux-gnu) libcurl/7.19.7 NSS/3.19.1 Basic ECC zlib/1.2.3 libidn/1.18 libssh2/1.4.2 sm/-" "req_time=0.037,req=c83b19b2-57fc-4498-ba14-1eacaeb90e5b"
10.16.185.241 - - [11/Jan/2017:19:50:53 +0530] "GET /candlepin/status/ HTTP/1.1" 200 489 "" "RHSM/1.0 (cmd=virt-who) sm/1.18.6-1.el6" "req_time=0.007,req=34428849-4da7-4a1e-9c1b-a706ae1d6224"
10.16.185.241 - - [11/Jan/2017:19:50:54 +0530] "GET /candlepin/ HTTP/1.1" 200 1378 "" "RHSM/1.0 (cmd=virt-who) sm/1.18.6-1.el6" "req_time=0.003,req=3ff5a42a-541a-43e1-a7c2-a11b263700d8"
10.16.185.241 - - [11/Jan/2017:19:50:56 +0530] "PUT /candlepin/consumers/6b900040-2c3e-4527-8ec6-6d8140e1ffb4 HTTP/1.1" 400 254 "" "RHSM/1.0 (cmd=virt-who) sm/1.18.6-1.el6" "req_time=0.568,req=fa333067-46a8-4965-b52d-1b3b877a517c"

candlepin.log
==============


2017-01-11 19:50:44,215 [thread=http-bio-8443-exec-1] [req=c83b19b2-57fc-4498-ba14-1eacaeb90e5b, org=] INFO  org.candlepin.common.filter.LoggingFilter - Request: verb=GET, uri=/candlepin/consumers/e927ead0-b628-45a1-9228-6b542e6f6f74/host
2017-01-11 19:50:44,251 [thread=http-bio-8443-exec-1] [req=c83b19b2-57fc-4498-ba14-1eacaeb90e5b, org=admin] WARN  org.candlepin.common.resteasy.filter.LinkHeaderResponseFilter - Method marked for pagination, but no page exists in the context.
2017-01-11 19:50:44,251 [thread=http-bio-8443-exec-1] [req=c83b19b2-57fc-4498-ba14-1eacaeb90e5b, org=admin] INFO  org.candlepin.common.filter.LoggingFilter - Response: status=204, content-type="null", time=36
2017-01-11 19:50:53,617 [thread=http-bio-8443-exec-8] [req=34428849-4da7-4a1e-9c1b-a706ae1d6224, org=] INFO  org.candlepin.common.filter.LoggingFilter - Request: verb=GET, uri=/candlepin/status/
2017-01-11 19:50:53,620 [thread=http-bio-8443-exec-8] [req=34428849-4da7-4a1e-9c1b-a706ae1d6224, org=] WARN  org.candlepin.common.resteasy.filter.LinkHeaderResponseFilter - Method marked for pagination, but no page exists in the context.
2017-01-11 19:50:53,624 [thread=http-bio-8443-exec-8] [req=34428849-4da7-4a1e-9c1b-a706ae1d6224, org=] INFO  org.candlepin.common.filter.LoggingFilter - Response: status=200, content-type="application/json", time=7
2017-01-11 19:50:54,972 [thread=http-bio-8443-exec-4] [req=3ff5a42a-541a-43e1-a7c2-a11b263700d8, org=] INFO  org.candlepin.common.filter.LoggingFilter - Request: verb=GET, uri=/candlepin/
2017-01-11 19:50:54,974 [thread=http-bio-8443-exec-4] [req=3ff5a42a-541a-43e1-a7c2-a11b263700d8, org=] WARN  org.candlepin.common.resteasy.filter.LinkHeaderResponseFilter - Method marked for pagination, but no page exists in the context.
2017-01-11 19:50:54,975 [thread=http-bio-8443-exec-4] [req=3ff5a42a-541a-43e1-a7c2-a11b263700d8, org=] INFO  org.candlepin.common.filter.LoggingFilter - Response: status=200, content-type="application/json", time=3
2017-01-11 19:50:56,688 [thread=http-bio-8443-exec-2] [req=fa333067-46a8-4965-b52d-1b3b877a517c, org=] INFO  org.candlepin.common.filter.LoggingFilter - Request: verb=PUT, uri=/candlepin/consumers/6b900040-2c3e-4527-8ec6-6d8140e1ffb4
2017-01-11 19:50:56,858 [thread=http-bio-8443-exec-2] [req=fa333067-46a8-4965-b52d-1b3b877a517c, org=admin] WARN  org.hibernate.engine.jdbc.spi.SqlExceptionHelper - SQL Error: 0, SQLState: 23505
2017-01-11 19:50:56,858 [thread=http-bio-8443-exec-2] [req=fa333067-46a8-4965-b52d-1b3b877a517c, org=admin] ERROR org.hibernate.engine.jdbc.spi.SqlExceptionHelper - ERROR: duplicate key value violates unique constraint "cp_consumer_hypervisor_ukey"
  Detail: Key (hypervisor_id, owner_id)=(80b90a9d-1a2e-e311-9b90-7446a0b3e6d5, 8ac6a3635945908f01594591acf50002) already exists.
2017-01-11 19:50:56,865 [thread=http-bio-8443-exec-2] [req=fa333067-46a8-4965-b52d-1b3b877a517c, org=admin] ERROR org.candlepin.resource.ConsumerResource - Problem updating unit:
javax.persistence.PersistenceException: org.hibernate.exception.ConstraintViolationException: could not execute statement
	at org.hibernate.jpa.spi.AbstractEntityManagerImpl.convert(AbstractEntityManagerImpl.java:1692) ~[hibernate-entitymanager-5.1.1.Final.jar:5.1.1.Final]
	at org.hibernate.jpa.spi.AbstractEntityManagerImpl.convert(AbstractEntityManagerImpl.java:1602) ~[hibernate-entitymanager-5.1.1.Final.jar:5.1.1.Final]
	at org.hibernate.jpa.spi.AbstractEntityManagerImpl.convert(AbstractEntityManagerImpl.java:1608) ~[hibernate-entitymanager-5.1.1.Final.jar:5.1.1.Final]
	at org.hibernate.jpa.spi.AbstractEntityManagerImpl.flush(AbstractEntityManagerImpl.java:1303) ~[hibernate-entitymanager-5.1.1.Final.jar:5.1.1.Final]
	at org.candlepin.model.AbstractHibernateCurator.flush(AbstractHibernateCurator.java:503) ~[AbstractHibernateCurator.class:na]
	at org.candlepin.model.AbstractHibernateCurator.save(AbstractHibernateCurator.java:498) ~[AbstractHibernateCurator.class:na]
	at com.google.inject.persist.jpa.JpaLocalTxnInterceptor.invoke(JpaLocalTxnInterceptor.java:58) ~[guice-persist-3.0.jar:na]
	at org.candlepin.model.ConsumerCurator.updateWithOptionalFlush(ConsumerCurator.java:406) ~[ConsumerCurator.class:na]
	at com.google.inject.persist.jpa.JpaLocalTxnInterceptor.invoke(JpaLocalTxnInterceptor.java:58) ~[guice-persist-3.0.jar:na]
	at org.candlepin.model.ConsumerCurator.update(ConsumerCurator.java:378) ~[ConsumerCurator.class:na]
	at com.google.inject.persist.jpa.JpaLocalTxnInterceptor.invoke(JpaLocalTxnInterceptor.java:58) ~[guice-persist-3.0.jar:na]
	at org.candlepin.resource.ConsumerResource.updateConsumer(ConsumerResource.java:801) ~[ConsumerResource.class:na]
	at com.google.inject.persist.jpa.JpaLocalTxnInterceptor.invoke(JpaLocalTxnInterceptor.java:66) ~[guice-persist-3.0.jar:na]
	at sun.reflect.GeneratedMethodAccessor264.invoke(Unknown Source) ~[na:na]
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43) ~[na:1.8.0_65]
	at java.lang.reflect.Method.invoke(Method.java:497) ~[na:1.8.0_65]
	at org.jboss.resteasy.core.MethodInjectorImpl.invoke(MethodInjectorImpl.java:137) [resteasy-jaxrs-3.0.10.Final.jar:na]
	at org.jboss.resteasy.core.ResourceMethodInvoker.invokeOnTarget(ResourceMethodInvoker.java:296) [resteasy-jaxrs-3.0.10.Final.jar:na]
	at org.jboss.resteasy.core.ResourceMethodInvoker.invoke(ResourceMethodInvoker.java:250) [resteasy-jaxrs-3.0.10.Final.jar:na]
	at org.jboss.resteasy.core.ResourceMethodInvoker.invoke(ResourceMethodInvoker.java:237) [resteasy-jaxrs-3.0.10.Final.jar:na]
	at org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:356) [resteasy-jaxrs-3.0.10.Final.jar:na]
	at org.jboss.resteasy.core.SynchronousDispatcher.invoke(SynchronousDispatcher.java:179) [resteasy-jaxrs-3.0.10.Final.jar:na]
	at org.jboss.resteasy.plugins.server.servlet.ServletContainerDispatcher.service(ServletContainerDispatcher.java:220) [resteasy-jaxrs-3.0.10.Final.jar:na]
	at org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:56) [resteasy-jaxrs-3.0.10.Final.jar:na]
	at org.jboss.resteasy.plugins.server.servlet.HttpServletDispatcher.service(HttpServletDispatcher.java:51) [resteasy-jaxrs-3.0.10.Final.jar:na]
	at javax.servlet.http.HttpServlet.service(HttpServlet.java:727) [tomcat-servlet-3.0-api.jar:na]
	at com.google.inject.servlet.ServletDefinition.doService(ServletDefinition.java:263) [guice-servlet-3.0.jar:na]
	at com.google.inject.servlet.ServletDefinition.service(ServletDefinition.java:178) [guice-servlet-3.0.jar:na]
	at com.google.inject.servlet.ManagedServletPipeline.service(ManagedServletPipeline.java:91) [guice-servlet-3.0.jar:na]
	at com.google.inject.servlet.FilterChainInvocation.doFilter(FilterChainInvocation.java:62) [guice-servlet-3.0.jar:na]
	at org.candlepin.servlet.filter.EventFilter.doFilter(EventFilter.java:61) [EventFilter.class:na]
	at com.google.inject.servlet.FilterDefinition.doFilter(FilterDefinition.java:163) [guice-servlet-3.0.jar:na]
	at com.google.inject.servlet.FilterChainInvocation.doFilter(FilterChainInvocation.java:58) [guice-servlet-3.0.jar:na]
	at org.candlepin.servlet.filter.ContentTypeHackFilter.doFilter(ContentTypeHackFilter.java:58) [ContentTypeHackFilter.class:na]
	at com.google.inject.servlet.FilterDefinition.doFilter(FilterDefinition.java:163) [guice-servlet-3.0.jar:na]
	at com.google.inject.servlet.FilterChainInvocation.doFilter(FilterChainInvocation.java:58) [guice-servlet-3.0.jar:na]
	at org.candlepin.common.filter.LoggingFilter.doFilter(LoggingFilter.java:90) [candlepin-common-2.0.3.jar:]
	at com.google.inject.servlet.FilterDefinition.doFilter(FilterDefinition.java:163) [guice-servlet-3.0.jar:na]
	at com.google.inject.servlet.FilterChainInvocation.doFilter(FilterChainInvocation.java:58) [guice-servlet-3.0.jar:na]
	at org.candlepin.servlet.filter.CandlepinPersistFilter.doFilter(CandlepinPersistFilter.java:48) [CandlepinPersistFilter.class:na]
	at com.google.inject.servlet.FilterDefinition.doFilter(FilterDefinition.java:163) [guice-servlet-3.0.jar:na]
	at com.google.inject.servlet.FilterChainInvocation.doFilter(FilterChainInvocation.java:58) [guice-servlet-3.0.jar:na]
	at org.candlepin.servlet.filter.CandlepinScopeFilter.doFilter(CandlepinScopeFilter.java:68) [CandlepinScopeFilter.class:na]
	at com.google.inject.servlet.FilterDefinition.doFilter(FilterDefinition.java:163) [guice-servlet-3.0.jar:na]
	at com.google.inject.servlet.FilterChainInvocation.doFilter(FilterChainInvocation.java:58) [guice-servlet-3.0.jar:na]
	at com.google.inject.servlet.ManagedFilterPipeline.dispatch(ManagedFilterPipeline.java:118) [guice-servlet-3.0.jar:na]
	at com.google.inject.servlet.GuiceFilter.doFilter(GuiceFilter.java:113) [guice-servlet-3.0.jar:na]
	at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:241) [catalina.jar:7.0.59]
	at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:208) [catalina.jar:7.0.59]
	at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:221) [catalina.jar:7.0.59]
	at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:122) [catalina.jar:7.0.59]
	at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:504) [catalina.jar:7.0.59]
	at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:170) [catalina.jar:7.0.59]
	at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103) [catalina.jar:7.0.59]
	at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:950) [catalina.jar:7.0.59]
	at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:116) [catalina.jar:7.0.59]
	at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:421) [catalina.jar:7.0.59]
	at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1074) [tomcat-coyote.jar:7.0.59]
	at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:611) [tomcat-coyote.jar:7.0.59]
	at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:314) [tomcat-coyote.jar:7.0.59]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [na:1.8.0_65]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [na:1.8.0_65]
	at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61) [tomcat-coyote.jar:7.0.59]
	at java.lang.Thread.run(Thread.java:745) [na:1.8.0_65]
Caused by: org.hibernate.exception.ConstraintViolationException: could not execute statement
	at org.hibernate.exception.internal.SQLStateConversionDelegate.convert(SQLStateConversionDelegate.java:112) ~[hibernate-core-5.1.1.Final.jar:5.1.1.Final]
	at org.hibernate.exception.internal.StandardSQLExceptionConverter.convert(StandardSQLExceptionConverter.java:42) ~[hibernate-core-5.1.1.Final.jar:5.1.1.Final]
	at org.hibernate.engine.jdbc.spi.SqlExceptionHelper.convert(SqlExceptionHelper.java:111) ~[hibernate-core-5.1.1.Final.jar:5.1.1.Final]
	at org.hibernate.engine.jdbc.spi.SqlExceptionHelper.convert(SqlExceptionHelper.java:97) ~[hibernate-core-5.1.1.Final.jar:5.1.1.Final]
	at org.hibernate.engine.jdbc.internal.ResultSetReturnImpl.executeUpdate(ResultSetReturnImpl.java:207) ~[hibernate-core-5.1.1.Final.jar:5.1.1.Final]
	at org.hibernate.engine.jdbc.batch.internal.NonBatchingBatch.addToBatch(NonBatchingBatch.java:45) ~[hibernate-core-5.1.1.Final.jar:5.1.1.Final]
	at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:2932) ~[hibernate-core-5.1.1.Final.jar:5.1.1.Final]
	at org.hibernate.persister.entity.AbstractEntityPersister.insert(AbstractEntityPersister.java:3432) ~[hibernate-core-5.1.1.Final.jar:5.1.1.Final]
	at org.hibernate.action.internal.EntityInsertAction.execute(EntityInsertAction.java:89) ~[hibernate-core-5.1.1.Final.jar:5.1.1.Final]
	at org.hibernate.engine.spi.ActionQueue.executeActions(ActionQueue.java:582) ~[hibernate-core-5.1.1.Final.jar:5.1.1.Final]
	at org.hibernate.engine.spi.ActionQueue.executeActions(ActionQueue.java:456) ~[hibernate-core-5.1.1.Final.jar:5.1.1.Final]
	at org.hibernate.event.internal.AbstractFlushingEventListener.performExecutions(AbstractFlushingEventListener.java:337) ~[hibernate-core-5.1.1.Final.jar:5.1.1.Final]
	at org.hibernate.event.internal.DefaultFlushEventListener.onFlush(DefaultFlushEventListener.java:39) ~[hibernate-core-5.1.1.Final.jar:5.1.1.Final]
	at org.hibernate.internal.SessionImpl.flush(SessionImpl.java:1295) ~[hibernate-core-5.1.1.Final.jar:5.1.1.Final]
	at org.hibernate.jpa.spi.AbstractEntityManagerImpl.flush(AbstractEntityManagerImpl.java:1300) ~[hibernate-entitymanager-5.1.1.Final.jar:5.1.1.Final]
	... 60 common frames omitted
Caused by: org.postgresql.util.PSQLException: ERROR: duplicate key value violates unique constraint "cp_consumer_hypervisor_ukey"
  Detail: Key (hypervisor_id, owner_id)=(80b90a9d-1a2e-e311-9b90-7446a0b3e6d5, 8ac6a3635945908f01594591acf50002) already exists.
	at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:2102) ~[postgresql-9.0-801.jdbc4.jar:na]
	at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1835) ~[postgresql-9.0-801.jdbc4.jar:na]
	at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:257) ~[postgresql-9.0-801.jdbc4.jar:na]
	at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:500) ~[postgresql-9.0-801.jdbc4.jar:na]
	at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:388) ~[postgresql-9.0-801.jdbc4.jar:na]
	at org.postgresql.jdbc2.AbstractJdbc2Statement.executeUpdate(AbstractJdbc2Statement.java:334) ~[postgresql-9.0-801.jdbc4.jar:na]
	at com.mchange.v2.c3p0.impl.NewProxyPreparedStatement.executeUpdate(NewProxyPreparedStatement.java:384) ~[c3p0-0.9.5.2.jar:0.9.5.2]
	at org.hibernate.engine.jdbc.internal.ResultSetReturnImpl.executeUpdate(ResultSetReturnImpl.java:204) ~[hibernate-core-5.1.1.Final.jar:5.1.1.Final]
	... 70 common frames omitted
2017-01-11 19:50:56,871 [thread=http-bio-8443-exec-2] [req=fa333067-46a8-4965-b52d-1b3b877a517c, org=admin] WARN  org.candlepin.common.resteasy.filter.LinkHeaderResponseFilter - Method marked for pagination, but no page exists in the context.
2017-01-11 19:50:56,872 [thread=http-bio-8443-exec-2] [req=fa333067-46a8-4965-b52d-1b3b877a517c, org=admin] WARN  org.candlepin.audit.EventSinkImpl - Rolling back hornetq transaction.
2017-01-11 19:50:56,885 [thread=http-bio-8443-exec-2] [req=fa333067-46a8-4965-b52d-1b3b877a517c, org=admin] INFO  org.candlepin.common.filter.LoggingFilter - Response: status=400, content-type="application/json", time=566

Comment 1 vritant 2017-01-12 15:25:45 UTC
Rehana,
could you provide the entire candlepin.log and access.log please?

Comment 2 Rehana 2017-01-12 17:35:22 UTC
Created attachment 1240042 [details]
candlepin.logs

Comment 3 Rehana 2017-01-12 17:37:23 UTC
Created attachment 1240043 [details]
access.logs

Comment 6 William Poteat 2017-01-25 21:39:20 UTC
There is a potential problem with the virt.uuid fact that might be the issue here. Can you rerun the test and see if this fact is reported on the guest consumer?

Comment 7 Rehana 2017-01-30 13:50:17 UTC
(In reply to William Poteat from comment #6)
> There is a potential problem with the virt.uuid fact that might be the issue
> here. Can you rerun the test and see if this fact is reported on the guest
> consumer?

Hi, 

As i mentioned in the description its not always reproducible. I tried to rerun the test today but i'm unable to reproduce the failure.

I will continue to work on it to get a reproducer.
thanks,
rehana


Note You need to log in before you can comment on or make changes to this bug.