Bug 1412258 - Update gcc for DTS-6.1
Summary: Update gcc for DTS-6.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Developer Toolset
Classification: Red Hat
Component: gcc
Version: DTS 6.1 RHEL 6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: alpha
: 6.1
Assignee: Jakub Jelinek
QA Contact: Michael Petlan
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-11 16:01 UTC by Marek Polacek
Modified: 2017-04-26 09:33 UTC (History)
7 users (show)

Fixed In Version: devtoolset-6-gcc-6.3.1-2.2.el6
Doc Type: Rebase: Bug Fixes Only
Doc Text:
GCC in the Developer Toolset 6 has been updated to version 6.3.1 from upstream. This update brings a number of bugfixes.
Clone Of:
Environment:
Last Closed: 2017-04-26 09:33:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1143 0 normal SHIPPED_LIVE devtoolset-6-gcc bug fix update 2017-04-26 13:30:26 UTC

Description Marek Polacek 2017-01-11 16:01:25 UTC

Comment 2 Michael Petlan 2017-02-23 14:09:33 UTC
Tested various DTS-6.1 gcc versions, currently the latest one is devtoolset-6-gcc-6.3.1-3.1.el{6,7}.

The testsuite results look very nice, comparation against results from dts-6.0 is OK too.

Found "regression-like" failures in the following testcases (which according to Marek is nothing serious):
 - gcc.dg/plugin/diagnostic-test-expressions-1.c
 - gcc.dg/pr70281.c

The rest looks OK. Thus I think we may move this bug to VERIFIED for devtoolset-6-gcc-6.3.1-3.1.el{6,7}.

Comment 4 errata-xmlrpc 2017-04-26 09:33:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1143


Note You need to log in before you can comment on or make changes to this bug.