Bug 1412295 - Document that gnocchi requires a ceph pool
Summary: Document that gnocchi requires a ceph pool
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: zstream
: 10.0 (Newton)
Assignee: Dan Macpherson
QA Contact: RHOS Documentation Team
URL:
Whiteboard:
: 1461951 1492141 1492142 (view as bug list)
Depends On:
Blocks: 1335596 1356451
TreeView+ depends on / blocked
 
Reported: 2017-01-11 17:02 UTC by Yurii Prokulevych
Modified: 2018-12-28 09:32 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: Known Issue
Doc Text:
The ceph driver need to have a ceph user and a pool already created. They can be created for example with: ceph osd pool create metrics 8 8 ceph auth get-or-create client.gnocchi mon "allow r" osd "allow rwx pool=metrics"
Clone Of:
Environment:
Last Closed: 2017-10-03 03:32:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1467704 None CLOSED rhosp-director: overcloud upgrade OSP9->OSP10 fails during major-upgrade-pacemaker phase. Stdout has the following:"WAR... 2019-11-05 19:38:02 UTC

Internal Links: 1467704

Comment 1 Sofer Athlan-Guyot 2017-06-30 10:14:15 UTC
Hi Dan,

we need to inform users of external ceph that they need a metrics pool to be created before doing the upgrade, as gnocchi will need it.

The exact name comes from  "GnocchiRbdPoolName" parameter which default to "metrics".

Asking Gulio for the exact command sequences.

Comment 2 Sofer Athlan-Guyot 2017-06-30 10:14:28 UTC
*** Bug 1461951 has been marked as a duplicate of this bug. ***

Comment 3 Giulio Fidente 2017-06-30 10:37:52 UTC
(In reply to Sofer Athlan-Guyot from comment #1)
> Hi Dan,
> 
> we need to inform users of external ceph that they need a metrics pool to be
> created before doing the upgrade, as gnocchi will need it.
> 
> The exact name comes from  "GnocchiRbdPoolName" parameter which default to
> "metrics".

this is correct, when using an external Ceph cluster the operator has to create in the Ceph cluster all the pools needed by OpenStack because the overcloud does not have the needed credentials to operate on the external cluster.

The Gnocchi backend can be 'swift', 'file' or 'rbd' (the last one is for Ceph) and can be configured using:

  GnocchiBackend:

When configured to use 'rbd', the Ceph pool name Gnocchi uses can be configured using:

  GnocchiRbdPoolName:

this is the name of the pool operators have to create in the external Ceph cluster.

By default the environment file we provide at environments/puppet-ceph-exeternal.yaml enables the 'rbd' backend for Gnocchi and uses 'metrics' as pool name.

Comment 4 Sofer Athlan-Guyot 2017-07-04 07:50:28 UTC
Thank Giulio for the detailed explanation.

Dan, do we need more ?  I think this is valid for all osp version (if Giulio could confirm), but let's start with osp10.  Would you need other bz for other version ?

Thanks,

Comment 5 Dan Macpherson 2017-07-06 12:49:14 UTC
I think I should be able to handle this for all versions using this BZ to track.

Comment 6 Sofer Athlan-Guyot 2017-07-17 11:30:22 UTC
Hi Dan,

I think this is relevant as well for https://bugzilla.redhat.com/show_bug.cgi?id=1467704 .  In that case the current doc text is not enough.  We should add some text saying that if you use:

 ExtraConfig:
    ceph_pools: [...]

during osp9/10 upgrade then you need to add the metrics pools to it.  Asking Giulio for confirmation and proper wording.

Comment 11 Andreas Karis 2017-09-18 14:40:11 UTC
*** Bug 1492141 has been marked as a duplicate of this bug. ***

Comment 13 Pradeep Kilambi 2017-09-25 22:00:03 UTC
*** Bug 1492142 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.