Bug 1412335 - [abrt] GConf2: g_settings_schema_get_value(): gsettings-data-convert killed by SIGTRAP
Summary: [abrt] GConf2: g_settings_schema_get_value(): gsettings-data-convert killed b...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: totem
Version: 7.3
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Bastien Nocera
QA Contact: Desktop QE
URL:
Whiteboard: abrt_hash:0c87bd3b3a786e484254cc674cb...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-11 19:21 UTC by Matěj Cepl
Modified: 2017-08-01 10:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 10:03:48 UTC
Target Upstream Version:


Attachments (Terms of Use)
File: backtrace (21.36 KB, text/plain)
2017-01-11 19:21 UTC, Matěj Cepl
no flags Details
File: cgroup (200 bytes, text/plain)
2017-01-11 19:21 UTC, Matěj Cepl
no flags Details
File: core_backtrace (2.55 KB, text/plain)
2017-01-11 19:21 UTC, Matěj Cepl
no flags Details
File: dso_list (1.77 KB, text/plain)
2017-01-11 19:21 UTC, Matěj Cepl
no flags Details
File: environ (1.11 KB, text/plain)
2017-01-11 19:21 UTC, Matěj Cepl
no flags Details
File: limits (1.29 KB, text/plain)
2017-01-11 19:21 UTC, Matěj Cepl
no flags Details
File: machineid (135 bytes, text/plain)
2017-01-11 19:21 UTC, Matěj Cepl
no flags Details
File: maps (10.05 KB, text/plain)
2017-01-11 19:21 UTC, Matěj Cepl
no flags Details
File: open_fds (376 bytes, text/plain)
2017-01-11 19:21 UTC, Matěj Cepl
no flags Details
File: proc_pid_status (1.15 KB, text/plain)
2017-01-11 19:21 UTC, Matěj Cepl
no flags Details
File: var_log_messages (3.31 KB, text/plain)
2017-01-11 19:21 UTC, Matěj Cepl
no flags Details
File: sosreport.tar.xz (8.86 MB, application/octet-stream)
2017-01-11 19:22 UTC, Matěj Cepl
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2315 0 normal SHIPPED_LIVE rhythmbox, gom, grilo, totem, libdmapsharing, compat-grilo02 update 2017-08-01 12:43:30 UTC

Description Matěj Cepl 2017-01-11 19:21:07 UTC
Description of problem:
I was just lgging to the freshly installed RHEL-7 with old (also RHEL-7, but older release) $HOME

Version-Release number of selected component:
GConf2-3.2.6-8.el7

Additional info:
reporter:       libreport-2.1.11.1
backtrace_rating: 4
cmdline:        gsettings-data-convert
crash_function: g_settings_schema_get_value
executable:     /usr/bin/gsettings-data-convert
global_pid:     4701
kernel:         3.10.0-514.2.2.el7.x86_64
pkg_fingerprint: 199E 2F91 FD43 1D51
pkg_vendor:     Red Hat, Inc.
reproducible:   Not sure how to reproduce the problem
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (5 frames)
 #2 g_settings_schema_get_value at /lib64/libgio-2.0.so.0
 #3 g_settings_schema_key_init at /lib64/libgio-2.0.so.0
 #4 g_settings_set_value at /lib64/libgio-2.0.so.0
 #5 g_settings_set at /lib64/libgio-2.0.so.0
 #6 handle_file

Comment 1 Matěj Cepl 2017-01-11 19:21:11 UTC
Created attachment 1239578 [details]
File: backtrace

Comment 2 Matěj Cepl 2017-01-11 19:21:13 UTC
Created attachment 1239579 [details]
File: cgroup

Comment 3 Matěj Cepl 2017-01-11 19:21:14 UTC
Created attachment 1239580 [details]
File: core_backtrace

Comment 4 Matěj Cepl 2017-01-11 19:21:16 UTC
Created attachment 1239581 [details]
File: dso_list

Comment 5 Matěj Cepl 2017-01-11 19:21:17 UTC
Created attachment 1239582 [details]
File: environ

Comment 6 Matěj Cepl 2017-01-11 19:21:19 UTC
Created attachment 1239583 [details]
File: limits

Comment 7 Matěj Cepl 2017-01-11 19:21:21 UTC
Created attachment 1239584 [details]
File: machineid

Comment 8 Matěj Cepl 2017-01-11 19:21:23 UTC
Created attachment 1239585 [details]
File: maps

Comment 9 Matěj Cepl 2017-01-11 19:21:24 UTC
Created attachment 1239586 [details]
File: open_fds

Comment 10 Matěj Cepl 2017-01-11 19:21:26 UTC
Created attachment 1239587 [details]
File: proc_pid_status

Comment 11 Matěj Cepl 2017-01-11 19:21:27 UTC
Created attachment 1239588 [details]
File: var_log_messages

Comment 12 Matěj Cepl 2017-01-11 19:22:21 UTC
Created attachment 1239589 [details]
File: sosreport.tar.xz

Comment 14 Marek Kašík 2017-01-13 15:58:17 UTC
This is a bug in Totem. The SIGTRAP happens when gsettings-data-convert tries to convert Totem's GConf2's settings to gsettings. There is gsetings' key 'debug' listed in its convert file which doesn't exist since this commit:

https://git.gnome.org/browse/totem/commit/?id=a05fe460313ff91cb048ae50a323b4c79a3b37c9

I'm reassigning this bug to totem.

Comment 16 Bastien Nocera 2017-03-10 15:36:49 UTC
Fixed in totem-3.22.1-1.el7
(Rebase bug 1387048)

Comment 18 Jiri Prajzner 2017-04-25 14:23:30 UTC
cannot reproduce

Comment 19 errata-xmlrpc 2017-08-01 10:03:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2315


Note You need to log in before you can comment on or make changes to this bug.