Bug 1412461 - MyService : Service name is randomly appended with timestamp
Summary: MyService : Service name is randomly appended with timestamp
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Automate
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: cfme-future
Assignee: Tina Fitzgerald
QA Contact: Shveta
URL:
Whiteboard: automate:service
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-12 05:16 UTC by Shveta
Modified: 2017-01-18 04:57 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-16 18:18:32 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
timestamp appended in some services (145.88 KB, image/png)
2017-01-12 05:16 UTC, Shveta
no flags Details

Description Shveta 2017-01-12 05:16:20 UTC
Created attachment 1239765 [details]
timestamp appended in some services

Description of problem:


Version-Release number of selected component (if applicable):
5.7.0.17.20161219135818_725f92f 

How reproducible:


Steps to Reproduce:
1. Created lot of service on an appliance.
2. Some services got the name assigned and some were appended by timestamp as shown in screenshot.
3.

Actual results:


Expected results:


Additional info:
1) No consistency , it gets appended randomly on any service

Comment 3 Tina Fitzgerald 2017-01-12 22:33:21 UTC
Hi Shveta,

Both the catalogiteminitialization and catalogbundleuinitialziation Automate methods generate a service name with the -date-time appended if there's no service name specified in the service dialog.  

Is it possible that the services in the attached screen shot were provisioned with a dialog that includes a service_name entry?

If not, can I access your appliance?

Thanks,
Tina

Comment 4 Shveta 2017-01-13 02:46:22 UTC
Hi Tina, 

I haven't touched anything under Automate - Explorer .
Please check https://10.8.197.166.
The statemachine used is  /Cloud/Orchestration/Provisioning/StateMachines/Provision/CatalogItemInitization

Thanks, 
Shveta

Comment 5 Tina Fitzgerald 2017-01-13 18:23:36 UTC
Hi Shveta,

All of the provisioned services in appliance referenced above contain the date and time suffix.

Can you point me to another appliance that shows the mixed service names?

Thanks,
Tina

Comment 6 Shveta 2017-01-13 19:38:37 UTC
Unfortunately I have lost the other appliance. 
This one has one service without timestamp if that helps.

Comment 7 Tina Fitzgerald 2017-01-13 20:52:22 UTC
Hi Shveta,

The provisioned service with no date time in the service name has an entry point of /Service/Provisioning/StateMachines/ServiceProvision_Template/default.

The entry points using catalogbundleinitialization/catalogiteminitialization create the service name with date time(unless overridden by a service dialog).

The /Service/Provisioning/StateMachines/ServiceProvision_Template/default instance should not be used as a service entry point. We'll be removing that instance in a future release.

Let me know if you have any questions.

Thanks,
Tina

Comment 8 Shveta 2017-01-13 23:01:33 UTC
So that means all services will have timestamp from now onwards ?

Comment 9 Tina Fitzgerald 2017-01-16 15:06:44 UTC
Yes, as long as catalogbundleinitialization or catalogiteminitialization is used as the entrypoint.

Can I close this ticket?

Comment 10 Shveta 2017-01-16 18:12:26 UTC
Since you are going to remove this entry point : /Service/Provisioning/StateMachines/ServiceProvision_Template/default.

Is there any other entry point that I can use that will not append timestamp and provision service ?
(needed for automation testing)

Yes , you can close .

Comment 11 Tina Fitzgerald 2017-01-16 18:18:14 UTC
Hi Shveta,

No, unfortunately not. You can supply your own service names if you create your test service dialogs with the service_name attribute.

I hope this helps.

Thanks,
Tina


Note You need to log in before you can comment on or make changes to this bug.