Bug 1412495 - [GSS](6.4.z) Problem using nested contexts in clustered environment
Summary: [GSS](6.4.z) Problem using nested contexts in clustered environment
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Clustering
Version: 6.3.3
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: CR1
: EAP 6.4.14
Assignee: Radoslav Husar
QA Contact: Jiří Bílek
URL:
Whiteboard:
Depends On:
Blocks: eap6414-payload
TreeView+ depends on / blocked
 
Reported: 2017-01-12 07:57 UTC by tmiyargi
Modified: 2020-02-14 18:27 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-23 08:25:25 UTC
Type: Bug


Attachments (Terms of Use)
reproducer (55.15 KB, application/zip)
2017-02-27 09:05 UTC, Jiří Bílek
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 279893 0 None None None 2017-02-24 08:04:23 UTC

Description tmiyargi 2017-01-12 07:57:15 UTC
Description of problem:
Facing problem using nested contexts, getting warning "ISPN000163: FileCacheStore ignored an unexpected file"

How reproducible:
One main context "a" several nested contexts "a/b" "a/c"

Comment 3 Jiří Bílek 2017-02-06 10:53:55 UTC
Could you please provide some reproducer for this issue?

Comment 5 Jiří Bílek 2017-02-27 09:05:38 UTC
Created attachment 1257971 [details]
reproducer

Steps to reproduce:
1. reproduce issue
  1.1. unzip eap 6.4.13
  1.2. run ./jboss-eap-6.4/bin/standalone.sh -c standalone-ha.xml
  1.3. deploy attached reproducer
  1.4. see server log
2. verifying issue
  2.1. install patch 6.4.14 to server used before
  2.2. run ./jboss-eap-6.4/bin/standalone.sh -c standalone-ha.xml
  2.3. see server log

Comment 6 Jiří Bílek 2017-02-27 09:19:42 UTC
Reopened because the issue still occurs on patched EAP.

Server gets warning message for each nested context e.g.:
WARN  [org.infinispan.loaders.file.FileCacheStore] (ServerService Thread Pool -- 13) ISPN000163: FileCacheStore ignored an unexpected file good in path /home/jbilek/Plocha/verifikace/6.4.14/bz1412495-clustering-nested-context/jboss-eap-6.4/standalone/data/infinispan/web/default-host/question. The store path should be dedicated!

Note:
This fix works on full-build eap 6.4.14. But if you will try reproducer firstly on 6.4.13, patch it to 6.4.14 and run it again it will fail.

Comment 7 Jiří Bílek 2017-02-28 08:02:54 UTC
Behavior is correct. EAP does not create unexpected directories for web context. If you still receive the warning message remove these directories.

Verified with EAP 6.4.14.CP.CR1

Please put in the KCS article about that you need to remove the directories if they are there.

Comment 8 Petr Penicka 2017-03-23 08:25:25 UTC
Released with EAP 6.4.14 on March 14 (ZIPs) and March 22 (RPMs).


Note You need to log in before you can comment on or make changes to this bug.