Bug 1412531 - [RHVH] Failed to add host - Package collectd-disk cannot be found
Summary: [RHVH] Failed to add host - Package collectd-disk cannot be found
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-ng
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ovirt-4.1.0-rc
: ---
Assignee: Ryan Barry
QA Contact: dguo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-12 08:28 UTC by Tareq Alayan
Modified: 2017-04-20 19:02 UTC (History)
13 users (show)

Fixed In Version: redhat-virtualization-host-4.1-20170112.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-20 19:02:26 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
deploy-log (18.39 KB, application/x-gzip)
2017-01-12 08:28 UTC, Tareq Alayan
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1114 0 normal SHIPPED_LIVE redhat-virtualization-host bug fix and enhancement update 2017-04-20 22:57:46 UTC

Description Tareq Alayan 2017-01-12 08:28:38 UTC
Created attachment 1239810 [details]
deploy-log

Description of problem:
Unable to add rhvh host to ovirt-engine 

Version-Release number of selected component (if applicable):
rhvh-4.1-0.20170111.0+1
ovirt-engine-4.1.0-0.4.master.20170111095612.git77d4436.el7.centos.noarch

How reproducible:
always

Steps to Reproduce:
1. add host to engine 
2.
3.

Actual results:
Package collectd-disk cannot be found.

Expected results:
installed and up 

Additional info:

Comment 1 Sandro Bonazzola 2017-01-12 09:15:27 UTC
Ryan please check the build content. collectd-disk is pulled in by ovirt-hosted-engine-setup and should be within RHV-H.
It's included in upstream node: http://jenkins.ovirt.org/job/ovirt-node-ng_ovirt-4.1-pre_build-artifacts-el7-x86_64/45/
The manifest shows: collectd-disk-5.7.0-1.el7.x86_64

Comment 3 Ryan Barry 2017-01-13 16:18:04 UTC
(In reply to Sandro Bonazzola from comment #1)
> Ryan please check the build content. collectd-disk is pulled in by
> ovirt-hosted-engine-setup and should be within RHV-H.

> The manifest shows: collectd-disk-5.7.0-1.el7.x86_64

This is not part of the list of dependencies in the most recent downstream build of ovirt-hosted-engine-setup (there are no collectd dependencies at all).

Comment 4 dguo 2017-01-17 03:06:58 UTC
Had used rhvh-4.1-0.20170116.0 to verified this bug:

Test step:
1.Install rhvh4.1

2.Check the collectd-disk package is existing
[root@dell-per730-34 ~]# imgbase w
[INFO] You are on rhvh-4.1-0.20170116.0+1
[root@dell-per730-34 ~]# rpm -qa|grep collectd-disk
collectd-disk-5.7.0-2.el7ost.x86_64

3.Setup a dhcp bond via cockpit

4.Add the host to engine via above bond successfully

Comment 5 errata-xmlrpc 2017-04-20 19:02:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1114


Note You need to log in before you can comment on or make changes to this bug.