Bug 1412538 - [RFE] %onerror from pykickstart
Summary: [RFE] %onerror from pykickstart
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.2
Hardware: Unspecified
OS: Unspecified
medium
unspecified
Target Milestone: rc
: 7.3
Assignee: Vendula Poncova
QA Contact: Release Test Team
Filip Hanzelka
URL:
Whiteboard:
Depends On: 1367663
Blocks: 1298243 1395321 1428469
TreeView+ depends on / blocked
 
Reported: 2017-01-12 08:54 UTC by Samantha N. Bueno
Modified: 2017-08-01 08:53 UTC (History)
9 users (show)

Fixed In Version: anaconda-21.48.22.102-1
Doc Type: Enhancement
Doc Text:
Kickstart installation failure automatically triggers `%onerror` scripts This enhancement makes sure that the `%onerror` sections in a kickstart file are run if the *Anaconda* installation fails. The scripts can be used to collect logs automatically for further examination. As a result of this update, when a traceback or another fatal error occurs during the installation, the installer performs the `%onerror` scripts and the `%traceback` scripts check if the error was caused by a traceback.
Clone Of: 1367663
: 1428469 (view as bug list)
Environment:
Last Closed: 2017-08-01 08:53:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2293 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2017-08-01 12:39:44 UTC

Comment 1 Samantha N. Bueno 2017-01-12 08:56:07 UTC
Required change due to pykickstart bug 1367663.

From Chris:
"""
The anaconda portion is this:                                                                     
                                                                                                  
https://github.com/rhinstaller/anaconda/commit/e470d17cce407a63cea65450f33666b16dcb390a           
                                                                                                  
But that would probably be very different on rhel7-branch.                                        
Conceptually, it's pretty easy to do though.
"""

Comment 3 Vendula Poncova 2017-03-08 09:56:27 UTC
The fix is available in a pull request: https://github.com/rhinstaller/anaconda/pull/985

Comment 5 Peter Kotvan 2017-04-25 12:56:47 UTC
I was able to verify this bug on RHEL-7.4-20170421.1 with anaconda-21.48.22.110-1.el7.

Comment 9 errata-xmlrpc 2017-08-01 08:53:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2293


Note You need to log in before you can comment on or make changes to this bug.