Bug 1412575 - In nano editor when navigating through file using cursor characters are getting changed.
Summary: In nano editor when navigating through file using cursor characters are getti...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nano
Version: 6.7
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Kamil Dudka
QA Contact: BaseOS QE - Apps
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-12 10:45 UTC by ptoshniw
Modified: 2020-07-16 09:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-13 18:41:28 UTC
Target Upstream Version:


Attachments (Terms of Use)
Video Showing the problem. (2.33 MB, video/quicktime)
2017-01-12 10:45 UTC, ptoshniw
no flags Details

Description ptoshniw 2017-01-12 10:45:53 UTC
Created attachment 1239847 [details]
Video Showing the problem.

Description of problem:
 In nano editor when navigating through file using cursor why characters are getting changed? 

Version-Release number of selected component (if applicable):
nano-2.0.9-7.el6.x86_64

How reproducible:

Using nano, navigating throughout the content of a file. I am using only the arrow keys to move the cursor throughout the file.  this movement should be one character at a time, and should not change any character after passing over it.  instead, you can see that it sometimes jumps multiple characters, and then gets confused and changes characters into other characters, as the cursor passes over them.  eventually, the words become illegible.  the cursors also extends beyond the end of the line when this happens [you can see this in the video at approximately 37 seconds].  refreshing [e.g. redrawing] the nano screen with control+l puts things back [you can see this happen in the video at approximately 22 seconds].  it then happens again.

This seems to be a problem with the tabs(1) command, in conjunction with nano   to exhibit the symptom, set a baseline by editing a file with nano and moving the cursor around [primarily back and forth on the same line]. Exit nano.  then, run the tabs command [for example, "tabs -4"].  then go back into nano and do the same exercise.

Actual results:

Expected results:


Additional info:

Comment 2 Kamil Dudka 2017-01-13 09:36:52 UTC
I am not able to reproduce it.  Please attach the file being edited and paste the exact sequence of commands to trigger the problem.

Comment 4 Kamil Dudka 2017-01-13 13:07:09 UTC
I opened a file and used arrows keys with no problem at all.  That is why I am asking you for additional details.  I need to recreate the problem locally so that I can further debug it.  The attached video does not help me with that.  Please do not clear the needinfo flag until all the required info is provided.

Comment 17 Kamil Dudka 2017-01-31 16:53:55 UTC
(In reply to ptoshniw from comment #15)
> I am in runlevel 3.

So you are referring to native TTY as I understand it.  I was connecting via SSH from Konsole (the terminal distributed with KDE), which prevented the bug from occurring.  However, I am able to reproduce the issue from el6 native TTY and also remotely using xterm.  So it is really matter of the terminal being used.

Comment 19 Kamil Dudka 2017-01-31 17:13:01 UTC
The issue is no longer reproducible on Fedora 24.  However, if I rebuild f24 nano on el6, the bug is there, whereas, if I rebuild el6 nano on f24, the bug is _not_ there.  This very likely means there is a change in behavior not caused by the code of nano.  I suspect ncurses but this will need further debugging...

Comment 20 Chris Williams 2017-06-13 18:41:28 UTC
Red Hat Enterprise Linux 6 transitioned to the Production 3 Phase on May 10, 2017.  During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.
 
The official life cycle policy can be reviewed here:
 
http://redhat.com/rhel/lifecycle
 
This issue does not appear to meet the inclusion criteria for the Production Phase 3 and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification.  Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:
 
https://access.redhat.com


Note You need to log in before you can comment on or make changes to this bug.