Bug 1412589 - Guest console can't be kept at pty serial if close and then reopen the guest window in virt-manager
Summary: Guest console can't be kept at pty serial if close and then reopen the guest ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager
Version: 6.9
Hardware: x86_64
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: virt-mgr-maint
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-12 11:30 UTC by mxie@redhat.com
Modified: 2017-01-13 07:27 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-12 12:24:31 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot1 (66.76 KB, image/png)
2017-01-12 11:30 UTC, mxie@redhat.com
no flags Details
screenshot2 (530.06 KB, image/png)
2017-01-12 11:31 UTC, mxie@redhat.com
no flags Details
virt-manager-debug.log (7.05 KB, text/plain)
2017-01-12 11:32 UTC, mxie@redhat.com
no flags Details

Description mxie@redhat.com 2017-01-12 11:30:40 UTC
Created attachment 1239857 [details]
screenshot1

Description of problem:
Guest console can't be kept at pty serial if close and then reopen the guest window in virt-manager

Version-Release number of selected component (if applicable):
virt-manager-0.9.0-34.el6.x86_64
python-virtinst-0.600.0-31.el6.noarch
libvirt-0.10.2-62.el6.x86_64
qemu-kvm-rhev-0.12.1.2-2.500.el6.x86_64


How reproducible:
100%

Steps to Reproduce:
1.Prepare a rhel6 guest in virt-manager and add "console=tty0 console=ttyS0,115200" to /boot/grub/grub.conf kernel line
2.Open guest's hardware details,click "Add Hardware" -> Serial -> Device type as "pty", Then finish
3.Power on the guest and click title option "View" -> Text console -> Serial 1
4.There are booting info showing in the guest console and will stop at log in interface, pls refer to screenshot1
5.Close guest window and open the guest window again in virt-manager, found the guest console turn into graphic mode. pls refer to screenshot2




Actual results:
As above description

Expected results:
Guest console can be kept at pty serial if close and then reopen the guest window in virt-manager

Additional info:
1.Can't reproduce this problem on rhel7.3

Comment 1 mxie@redhat.com 2017-01-12 11:31:06 UTC
Created attachment 1239858 [details]
screenshot2

Comment 2 mxie@redhat.com 2017-01-12 11:32:20 UTC
Created attachment 1239859 [details]
virt-manager-debug.log

Comment 3 Pavel Hrdina 2017-01-12 12:24:31 UTC
This is not a bug, virt-manager always tries to open graphical console if you open the guest details.  If you switch to serial console and close the details window the preference between graphical or serial console is not stored and the next time you'll get graphical console.

Comment 4 mxie@redhat.com 2017-01-13 01:59:10 UTC
(In reply to Pavel Hrdina from comment #3)
> This is not a bug, virt-manager always tries to open graphical console if
> you open the guest details.  If you switch to serial console and close the
> details window the preference between graphical or serial console is not
> stored and the next time you'll get graphical console.

Hi Pavel,

But rhel7 could keep guest console at serial no matter close and open the guest window, as you said, should file a bug on rhel7?

Comment 5 Pavel Hrdina 2017-01-13 07:27:31 UTC
Hi, I didn't know that virt-manager on rhel7 keeps the serial console open.  I guess that someone implemented it.  The virt-manager on rhel7 is way much newer than the one in rhel6 and has a lot of new features that are not and will not be in the old virt-manager.

I'm changing the NOTABUG to WONTFIX as we will not backport every feature into rhel6. Thanks for the info.


Note You need to log in before you can comment on or make changes to this bug.