Bug 1412624 - cdn-sync with parameter http-proxy causes ERROR: invalid arguments to setopt
Summary: cdn-sync with parameter http-proxy causes ERROR: invalid arguments to setopt
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization
Version: 580
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gennadii Altukhov
QA Contact: Pavel Studeník
URL:
Whiteboard:
Depends On:
Blocks: 1340444
TreeView+ depends on / blocked
 
Reported: 2017-01-12 13:18 UTC by Pavel Studeník
Modified: 2017-06-21 12:10 UTC (History)
3 users (show)

Fixed In Version: spacewalk-backend-2.5.3-53-sat
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-21 12:10:46 UTC
Target Upstream Version:


Attachments (Terms of Use)
ascii_to_pune (670 bytes, patch)
2017-01-16 10:41 UTC, Gennadii Altukhov
no flags Details | Diff

Description Pavel Studeník 2017-01-12 13:18:39 UTC
Description of problem:

>>> cdn-sync -c redhat-rhn-proxy-5.7-server-s390x-6 --http-proxy squid.example.com:3128

08:07:42 ======================================
08:07:42 | Channel: redhat-rhn-proxy-5.7-server-s390x-6
08:07:42 ======================================
08:07:42 Sync of channel started.
08:07:42 Repo URL: https://cdn.stage.redhat.com/content/dist/rhel/system-z/6/6Server/s390x/satellite-proxy/5.7/os
08:07:42 ERROR: invalid arguments to setopt
08:07:42 Sync of channel completed in 0:00:00.
08:07:42 Total time: 0:00:00


Version-Release number of selected component (if applicable):
spacewalk-backend-cdn-2.5.3-48.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. run cdn-sycn through proxy squid

Actual results:
it doesn't work through proxy squid

Expected results:
it works through proxy squid

Comment 1 Gennadii Altukhov 2017-01-16 10:41:24 UTC
Created attachment 1241166 [details]
ascii_to_pune

to make ascii_to_pune compatible with ascii_to_puny it should return 'str' object, not 'unicode'

Comment 2 Gennadii Altukhov 2017-01-16 10:42:44 UTC
This bug is not reproducible in upstream due to different code in upstream and SATELLITE-5.8, see a commit in SATELLITE-5.8 branch: 80d9696ae478bf25c5b0217bfeb8496c8acbe3a0

to make old function 'idn_ascii_to_pune' compatible with new 'idn_ascii_to_puny' we need to apply the patch in the attachment.

Comment 6 Pavel Studeník 2017-02-09 13:48:03 UTC
Verified.

spacewalk-backend-cdn-2.5.3-59.el6sat.noarch 
spacewalk-backend-2.5.3-59.el6sat.noarch


Note You need to log in before you can comment on or make changes to this bug.