Bug 1412640 - Should installer run 'yum clean' during upgrade?
Summary: Should installer run 'yum clean' during upgrade?
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades
Version: 580
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomáš Kašpárek
QA Contact: Lukáš Hellebrandt
URL:
Whiteboard:
Depends On:
Blocks: sat580-upgrades
TreeView+ depends on / blocked
 
Reported: 2017-01-12 14:00 UTC by Lukáš Hellebrandt
Modified: 2017-06-21 12:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-21 12:18:08 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Lukáš Hellebrandt 2017-01-12 14:00:20 UTC
Description of problem:
When upgrading Satellite (for some reason, I have only been able to reproduce this on s390x), the upgrade fails with:

---> Package spacewalk-setup-jabberd.noarch 0:2.3.2-1.el6sat will be an update
Error: failed to retrieve repodata/51e2297081b5e027babe8de3c551df5be7702aa37383900507491de558220dfe-filelist
s.xml.gz from rhel-s390x-server-6
       error was [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"

I then need to 'yum clean all', run upgrade again and everything works. Should we run yum clean during upgrade?

I think it is caused by different path to packages ($YUM0/Satellite vs $YUM0).


How reproducible:
Sometimes

Steps to Reproduce:
1. ./install.pl --upgrade
2. cat /var/log/rhn/rhn_installation.log

Actual results:
Error shown above

Expected results:
Successfull upgrade

Comment 5 Lukáš Hellebrandt 2017-02-15 10:10:17 UTC
There's a typo in the error message: s/metadat/metadata/

Comment 7 Lukáš Hellebrandt 2017-02-15 16:39:22 UTC
Verified with rhn-upgrade-5.8.0.12-1, Satellite 570 on EmbPostgreSQL RHEL6 s390x -> 5.8.

Upgrade now works without error even on freshly installed Satellite. Also when manually making yum to download repodata for the old repo before upgrade, everything works.


Note You need to log in before you can comment on or make changes to this bug.