Bug 1412668 - youtube-dl: ERROR: Signature extraction failed
Summary: youtube-dl: ERROR: Signature extraction failed
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: youtube-dl
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Till Maas
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-12 14:16 UTC by Ralf Corsepius
Modified: 2017-02-16 19:46 UTC (History)
1 user (show)

Fixed In Version: youtube-dl-2017.01.10-1.fc25 youtube-dl-2017.01.10-1.fc24 youtube-dl-2017.01.31-1.el7 youtube-dl-2017.01.31-1.el6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-16 16:48:29 UTC
Type: Bug


Attachments (Terms of Use)

Description Ralf Corsepius 2017-01-12 14:16:28 UTC
Description of problem:

Seems to me, as if something at youtube has changed incompatibly to the version of youtube-dl in Fedora, rendering Fedora's youtube-dl totally dysfunctional:

# youtube-dl https://www.youtube.com/watch?v=....
...
ERROR: Signature extraction failed: Traceback (most recent call last):
  File "/usr/lib/python3.5/site-packages/youtube_dl/extractor/youtube.py", line 1005, in _decrypt_signature
    video_id, player_url, s
  File "/usr/lib/python3.5/site-packages/youtube_dl/extractor/youtube.py", line 932, in _extract_signature_function
    cache_res = res(test_string)
  File "/usr/lib/python3.5/site-packages/youtube_dl/extractor/youtube.py", line 984, in <lambda>
    return lambda s: initial_function([s])
  File "/usr/lib/python3.5/site-packages/youtube_dl/jsinterp.py", line 254, in resf
    res, abort = self.interpret_statement(stmt, local_vars)
  File "/usr/lib/python3.5/site-packages/youtube_dl/jsinterp.py", line 55, in interpret_statement
    v = self.interpret_expression(expr, local_vars, allow_recursion)
  File "/usr/lib/python3.5/site-packages/youtube_dl/jsinterp.py", line 174, in interpret_expression
    return obj[member](argvals)
KeyError: 'Ai'
...

Version-Release number of selected component (if applicable):
youtube-dl-2016.12.22-1

How reproducible:
Always

Steps to Reproduce:
1. Try to download an arbitrary video from youtube

Additional info:
This seems fixed upstream in youtube-dl-2017.01.10

Comment 1 fednuc 2017-01-12 19:44:16 UTC
Confirmed. Maintainers please bump the version when you can since it's the biggest site ;)

Comment 2 Fedora Update System 2017-01-12 23:17:09 UTC
youtube-dl-2017.01.10-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-bd8b161195

Comment 3 Fedora Update System 2017-01-12 23:17:25 UTC
youtube-dl-2017.01.10-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-0cf46facbe

Comment 4 Fedora Update System 2017-01-13 07:48:36 UTC
youtube-dl-2017.01.10-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-bd8b161195

Comment 5 Fedora Update System 2017-01-13 08:32:56 UTC
youtube-dl-2017.01.10-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-0cf46facbe

Comment 6 Fedora Update System 2017-01-13 18:13:06 UTC
youtube-dl-2017.01.10-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-57fc0f7fb8

Comment 7 Fedora Update System 2017-01-13 18:13:24 UTC
youtube-dl-2017.01.10-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-b1411f6867

Comment 8 Fedora Update System 2017-01-14 06:19:55 UTC
youtube-dl-2017.01.10-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-57fc0f7fb8

Comment 9 Fedora Update System 2017-01-14 07:48:59 UTC
youtube-dl-2017.01.10-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-b1411f6867

Comment 10 Fedora Update System 2017-01-16 19:51:29 UTC
youtube-dl-2017.01.10-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2017-01-16 20:50:26 UTC
youtube-dl-2017.01.10-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2017-02-01 15:53:57 UTC
youtube-dl-2017.01.31-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-d2a3e6eb36

Comment 13 Fedora Update System 2017-02-01 15:54:12 UTC
youtube-dl-2017.01.31-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-ceeb7c5e80

Comment 14 Fedora Update System 2017-02-01 22:19:04 UTC
youtube-dl-2017.01.31-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-ceeb7c5e80

Comment 15 Fedora Update System 2017-02-02 03:48:51 UTC
youtube-dl-2017.01.31-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2017-d2a3e6eb36

Comment 16 Fedora Update System 2017-02-16 16:48:29 UTC
youtube-dl-2017.01.31-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2017-02-16 19:46:33 UTC
youtube-dl-2017.01.31-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.