Bug 1412674 - Your Organization -> Configuration -> ISE
Summary: Your Organization -> Configuration -> ISE
Keywords:
Status: CLOSED DUPLICATE of bug 1410083
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Upgrades
Version: 580
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tomáš Kašpárek
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-12 14:29 UTC by Lukáš Hellebrandt
Modified: 2017-01-12 14:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-12 14:41:22 UTC
Target Upstream Version:


Attachments (Terms of Use)
catalina.out (4.22 KB, text/plain)
2017-01-12 14:29 UTC, Lukáš Hellebrandt
no flags Details

Description Lukáš Hellebrandt 2017-01-12 14:29:16 UTC
Created attachment 1239957 [details]
catalina.out

Description of problem:
Going to "Your Organization -> Configuration" (/rhn/multiorg/OrgConfigDetails.do) results in ISE on my Satellite upgraded from 5.7 Ora to 5.8 Emb on s390x.

I think used schema upgrade path looks fishy (but maybe it is okay to start with 5.8 after Ora->Emb migration):
===================================
# spacewalk-schema-upgrade
Schema upgrade: [satellite-schema-5.8.0.17-1.el6sat] -> [satellite-schema-5.8.0.18-1.el6sat]
Searching for upgrade path: [satellite-schema-5.8.0.17-1] -> [satellite-schema-5.8.0.18-1]
Searching for upgrade path: [satellite-schema-5.8.0.17] -> [satellite-schema-5.8.0.18]
The schema version is the same, except for the dist tag.
Searching for upgrade path: [satellite-schema-5.8.0] -> [satellite-schema-5.8.0]
The path: [satellite-schema-5.8.0]
Planning to run spacewalk-sql with [/var/log/spacewalk/schema-upgrade/20170112-084226-script.sql]

Plase make sure you have a valid backup of your database before continuing.

Hit Enter to continue or Ctrl+C to interrupt:
Executing spacewalk-sql, the log is in [/var/log/spacewalk/schema-upgrade/20170112-084226-to-satellite-schem
a-5.8.0.log].
The database schema was upgraded to version [satellite-schema-5.8.0.18-1.el6sat].
===================================

Spacewalk-schema-upgrade log:
===================================
UPDATE 1
COMMIT
CREATE FUNCTION
 create_varnull_constriants
----------------------------
                          0
(1 row)

INSERT 0 1
COMMIT
===================================

The catalina.out log file attached.

How reproducible:
1 of 1 attempts on RHEL6 s390x 5.7 Ora -> RHEL6 s390x 5.8 Emb

Steps to Reproduce:
1. Your Organization -> Configuration -> ISE

Actual results:
ISE

Expected results:
Working page

Additional info:
Can you confirm that the used upgrade path is correct?

Comment 2 Lukáš Hellebrandt 2017-01-12 14:41:22 UTC

*** This bug has been marked as a duplicate of bug 1410083 ***


Note You need to log in before you can comment on or make changes to this bug.