Bug 1412684 - Issue with fog-openstack 'update_quota.rb'
Summary: Issue with fog-openstack 'update_quota.rb'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.6.4
Assignee: Scott Seago
QA Contact: Ola Pavlenko
URL:
Whiteboard: openstack
Depends On: 1390147
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-12 14:41 UTC by Satoe Imaishi
Modified: 2019-12-16 07:29 UTC (History)
9 users (show)

Fixed In Version: 5.6.4.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1390147
Environment:
Last Closed: 2017-03-09 17:07:39 UTC
Category: ---
Cloudforms Team: Openstack
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0474 0 normal SHIPPED_LIVE CFME 5.6.4 bug fixes and enhancement update 2017-03-09 22:03:14 UTC

Comment 2 CFME Bot 2017-01-30 15:11:17 UTC
New commit detected on ManageIQ/manageiq/darga:
https://github.com/ManageIQ/manageiq/commit/a6c651f4b7e5cf540af0276dd9571bec8b2f6aac

commit a6c651f4b7e5cf540af0276dd9571bec8b2f6aac
Author:     Satoe Imaishi <simaishi@redhat.com>
AuthorDate: Thu Jan 12 09:42:43 2017 -0500
Commit:     Satoe Imaishi <simaishi@redhat.com>
CommitDate: Mon Jan 30 10:07:51 2017 -0500

    Merge pull request #13417 from sseago/tenant-id-quota-set
    
    [EUWE] Upgrade fog-openstack to 0.1.19
    (cherry picked from commit 01d4d851f829c8670d4b2561114ba10ad4dff96b)
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1412684

 gems/pending/Gemfile | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

Comment 3 Scott Seago 2017-01-30 17:15:10 UTC
The backport PR is merged.

Comment 4 Ronnie Rasouli 2017-02-05 14:55:47 UTC
There is no tenant CRUD in CFME 5.6.4.0

Comment 5 Tzu-Mainn Chen 2017-02-06 14:10:29 UTC
AFAIK this has nothing to do with tenant CRUD.  Scott, can you give an example of how to access this functionality?

Comment 6 Scott Seago 2017-02-06 14:22:39 UTC
This bug was originally reported in 5.6. I never got a response from the original reporter as to exactly how they hit the bug originally. I was able to reproduce it by invoking the reported fog-openstack API commands directly in the rails console, since I was never able to figure out how to hit the bug via the Web UI.

So you probably have 2 options:
1) Find out from sacpatil@redhat.com how the bug was originally discovered and verify it the same way
2) verify by manually running fog-openstack update quota API calls.

Comment 7 Ronnie Rasouli 2017-02-07 11:21:40 UTC
Please provide steps to reproduce, in 5.6 there isn't a method to create new tenants, please explain in details how did they create the tenants.
by openstack CLI? since the options does not exist on UI

Comment 9 Sachin 2017-02-22 07:49:20 UTC
Hello Scott,

> Find out how the bug was originally discovered and verify it the same way

CU never disclosed how they called update_quote() I can only guess that it was called using automate method. If need I can ask CU.

> verify by manually running fog-openstack update quota API calls.

Running update_quota API calls should be a good test

Comment 11 errata-xmlrpc 2017-03-09 17:07:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0474.html


Note You need to log in before you can comment on or make changes to this bug.