Bug 1412691 - task_cwd_path results in an in-kernel memory leak
Summary: task_cwd_path results in an in-kernel memory leak
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: systemtap
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Frank Ch. Eigler
QA Contact: Martin Cermak
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-12 15:03 UTC by Kyle Walker
Modified: 2020-12-14 08:00 UTC (History)
4 users (show)

Fixed In Version: systemtap-3.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 09:34:40 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch to issue a "put_task_struct" if needed prior to the return operation. (524 bytes, text/plain)
2017-01-12 15:06 UTC, Kyle Walker
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2301 0 normal SHIPPED_LIVE systemtap bug fix and enhancement update 2017-08-01 12:41:08 UTC

Description Kyle Walker 2017-01-12 15:03:07 UTC
Description of problem:
 The "task_cwd_path" tapset function can result in a memory leak. The function calls get_task_struct(task) early on, but does not have a corresponding put_task_struct() if the task->fs member is present.

Version-Release number of selected component (if applicable):
 systemtap-3.0-7.el7.x86_64

How reproducible:
 Easily

Steps to Reproduce:
1. Install systemtap required packages
2. Run the following script for a short interval

    $ stap -e 'probe kprocess.exit {path=fullpath_struct_path(task_cwd_path(task_current()));printf("%s\n", path)}'

3. Monitor the "KernelStack" field in /proc/meminfo over time

Actual results:
 The "KernelStack" counter continually increases

Expected results:
 The "KernelStack" counter increases and decreases as task_structs are created/freed.

Additional info:

Comment 1 Kyle Walker 2017-01-12 15:06:52 UTC
Created attachment 1239984 [details]
Patch to issue a "put_task_struct" if needed prior to the return operation.

Comment 2 Frank Ch. Eigler 2017-01-12 15:12:49 UTC
Thanks a lot, Kyle, merged your patch upstream, and should be in the rhel7.4 rebase.

Comment 3 Kyle Walker 2017-01-12 18:02:05 UTC
@Frank,

No problem at all! Thank you for the merge!

- Kyle Walker

Comment 6 errata-xmlrpc 2017-08-01 09:34:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2301


Note You need to log in before you can comment on or make changes to this bug.