Bug 1412725 - [API] Setting Custom Compatibility Version for a VM via REST api to a none/empty value is not working
Summary: [API] Setting Custom Compatibility Version for a VM via REST api to a none/em...
Keywords:
Status: CLOSED DUPLICATE of bug 1464819
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: RestAPI
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ovirt-4.2.0
: ---
Assignee: Sharon Gratch
QA Contact: Pavel Stehlik
URL:
Whiteboard:
Depends On:
Blocks: 1464819
TreeView+ depends on / blocked
 
Reported: 2017-01-12 16:00 UTC by Sharon Gratch
Modified: 2017-07-31 09:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1464819 (view as bug list)
Environment:
Last Closed: 2017-07-31 09:48:36 UTC
oVirt Team: Virt
rule-engine: ovirt-4.2?
tjelinek: planning_ack?
tjelinek: devel_ack+
tjelinek: testing_ack?


Attachments (Terms of Use)

Description Sharon Gratch 2017-01-12 16:00:48 UTC
Description of problem:
Trying to set the Custom Compatibility Version of a VM to an empty value via REST api (in order to take the Custom Compatibility Version value of the Cluster) is not supported, 

This should be done by running the following:
POST /ovirt-engine/api/vms/<vmid>
<vm>
    <custom_compatibility_version/>
</vm>

but it fails with an error: 
<detail>
For correct usage, see: http://butterfly.usersys.redhat.com:8080/ovirt-engine/api/v4/model#services/vm-graphics-consoles/methods/add
</detail>
<reason>Request syntactically incorrect.</reason>

Version-Release number of selected component (if applicable):
4.1 master

How reproducible:
100%

Steps to Reproduce:
1.Try to create a vm or edit a vm and set custom_compatibility_version attribute to an empty value:
<vm>
    <custom_comaptibility_version/>
</vm>

Actual results:
It failed with error:
<detail>
For correct usage, see: http://butterfly.usersys.redhat.com:8080/ovirt-engine/api/v4/model#services/vm-graphics-consoles/methods/add
</detail>
<reason>Request syntactically incorrect.</reason>

Expected results:
It should succeeded.

Comment 1 Sharon Gratch 2017-07-20 09:26:13 UTC
Tomas, this bug is a duplication of bug 1464819 and not dependency of it, right?
Therefore I think it can be closed. Please confirm...

Comment 2 Sharon Gratch 2017-07-31 09:48:36 UTC

*** This bug has been marked as a duplicate of bug 1464819 ***


Note You need to log in before you can comment on or make changes to this bug.