Bug 1412797 - option -m is not mentioned in matchpathcon usage message
Summary: option -m is not mentioned in matchpathcon usage message
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libselinux
Version: 7.3
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Petr Lautrbach
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-12 20:00 UTC by Milos Malik
Modified: 2017-08-01 17:43 UTC (History)
6 users (show)

Fixed In Version: libselinux-2.5-10.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-08-01 17:43:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1853 0 normal SHIPPED_LIVE libselinux bug fix update 2017-08-01 18:03:23 UTC

Description Milos Malik 2017-01-12 20:00:10 UTC
Description of problem:
* the -m option is described in man page of matchpathcon, but is not mentioned in its usage message

OPTIONS
       -m type
              Force  file  type  for  the  lookup.  Valid types are file, dir,
              pipe, chr_file, blk_file, lnk_file, sock_file.


Version-Release number of selected component (if applicable):
libselinux-utils-2.5-6.el7.x86_64
libselinux-ruby-2.5-6.el7.x86_64
libselinux-2.5-6.el7.x86_64
libselinux-devel-2.5-6.el7.x86_64
libselinux-python-2.5-6.el7.x86_64

How reproducible:
* always

Steps to Reproduce:
# matchpathcon -m
matchpathcon: option requires an argument -- 'm'
usage:  matchpathcon [-N] [-n] [-f file_contexts] [ -P policy_root_path ] [-p prefix] [-Vq] path...
# matchpathcon -m xyz
matchpathcon: mode xyz is invalid
#

Actual results:
usage:  matchpathcon [-N] [-n] [-f file_contexts] [ -P policy_root_path ] [-p prefix] [-Vq] path...

Expected results:
usage:  matchpathcon [-N] [-n] [-m mode] [-f file_contexts] [ -P policy_root_path ] [-p prefix] [-Vq] path...

Comment 1 Petr Lautrbach 2017-03-06 12:33:44 UTC
--- a/libselinux/utils/matchpathcon.c
+++ b/libselinux/utils/matchpathcon.c
@@ -15,7 +15,7 @@
 static void usage(const char *progname)
 {
        fprintf(stderr,
-               "usage:  %s [-N] [-n] [-f file_contexts] [ -P policy_root_path ] [-p prefix] [-Vq] path...\n",
+               "usage:  %s [-V] [-N] [-n] [-m type] [-f file_contexts_file] [-p prefix] [-P policy_root_path] filepath...\n",
                progname);
        exit(1);
 }

Comment 5 errata-xmlrpc 2017-08-01 17:43:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1853


Note You need to log in before you can comment on or make changes to this bug.