Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1412800 - huge slowdown of egrep
Summary: huge slowdown of egrep
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: grep
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-12 20:17 UTC by Fabrice Bellet
Modified: 2017-02-24 22:50 UTC (History)
3 users (show)

Fixed In Version: grep-2.27-2.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-24 22:50:10 UTC
Type: Bug


Attachments (Terms of Use)

Description Fabrice Bellet 2017-01-12 20:17:55 UTC
I noticed a huge slow down of egrep after upgrading from Fedora 24 to Fedora 25. Basically running the command "egrep  'selected pair:|STATE-CHANGE' empathy-call.log", on a file whose size is 2GB, with 14213617 lines, and 11456 matching lines.

It takes ~5s on Fedora 24, and 90 seconds on Fedora 25.

Comment 1 Fabrice Bellet 2017-01-12 21:38:10 UTC
The problem is in 2.27, and has been fixed upstream by commit a43f8e6e83 in gnulib.

Comment 2 Andy Blanchard 2017-02-20 12:31:51 UTC
Seeing this here too with some major issues for logfile processing.  Is there any ETA on the fix working its way downstream since there's no sign of an update to grep in testing yet?

Comment 3 Andy Blanchard 2017-02-20 12:41:20 UTC
FYI, as a workaround, reverting to v2.26-2.fc25 from Koji solves the performance issues but re-introduces the bugs fixed in v2.27 of grep, so pick your poison:

https://debbugs.gnu.org/cgi/bugreport.cgi?bug=24941
https://koji.fedoraproject.org/koji/buildinfo?buildID=807299

Comment 4 Fedora Update System 2017-02-20 21:39:49 UTC
grep-2.27-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-1d6cb60597

Comment 5 Fedora Update System 2017-02-22 21:07:32 UTC
grep-2.27-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-1d6cb60597

Comment 6 Fedora Update System 2017-02-24 22:50:10 UTC
grep-2.27-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.