Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1412828 - dnf upgrad of cockpit fails for requirement not available (cockpit-bridge)
Summary: dnf upgrad of cockpit fails for requirement not available (cockpit-bridge)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: cockpit
Version: 26
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Dominik Perpeet
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-12 22:14 UTC by George R. Goffe
Modified: 2017-09-04 10:43 UTC (History)
5 users (show)

Fixed In Version: cockpit-129
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-09-04 10:43:37 UTC
Type: Bug


Attachments (Terms of Use)

Description George R. Goffe 2017-01-12 22:14:26 UTC
Description of problem:

upgrade of cockpit fails with "none of the providers can be installed" messages, see below

Version-Release number of selected component (if applicable):
cockpit-126-1.fc25.x86_64


How reproducible:
always

Steps to Reproduce:
1.see below
2.
3.

Actual results:
see below

Expected results:
successful upgrade

Additional info:

dnf --best upgrade
Last metadata expiration check: 0:00:35 ago on Thu Jan 12 14:08:47 2017.
Error: nothing provides python2-rosdep >= 0.10.25 needed by python2-bloom-0.5.23-1.fc25.noarch.
package cockpit-shell-126-1.fc25.noarch requires cockpit-bridge = 126-1.fc25, but none of the providers can be installed.
package cockpit-shell-126-1.fc25.noarch requires cockpit-bridge = 126-1.fc25, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)

Comment 1 Stef Walter 2017-01-13 10:56:22 UTC
Patches upstream to fix building in Fedora 26. This should be fixed with a new Cockpit 129 release next week:

https://github.com/cockpit-project/cockpit/pull/5732

Comment 2 George R. Goffe 2017-01-13 15:22:23 UTC
Stef,

Cool.

Thanks for all your hard work.

Regards,

George...

Comment 3 David Juran 2017-01-15 11:25:41 UTC
Also affecting F25:

Error: package cockpit-shell-126-1.fc25.noarch requires cockpit-bridge = 126-1.fc25, but none of the providers can be installed.
package cockpit-shell-126-1.fc25.noarch requires cockpit-bridge = 126-1.fc25, but none of the providers can be installed

Comment 4 Fedora End Of Life 2017-02-28 10:56:49 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 26 development cycle.
Changing version to '26'.

Comment 5 Dominik Perpeet 2017-09-04 10:43:37 UTC
(In reply to Stef Walter from comment #1)
> Patches upstream to fix building in Fedora 26. This should be fixed with a
> new Cockpit 129 release next week:
> 
> https://github.com/cockpit-project/cockpit/pull/5732

It appears this worked.


Note You need to log in before you can comment on or make changes to this bug.