Bug 1412870 - [RFE] Disable the "Publish New Version" button if no changes have been made to a Content View
Summary: [RFE] Disable the "Publish New Version" button if no changes have been made t...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Views
Version: 6.2.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-13 02:23 UTC by Russell Dickenson
Modified: 2019-08-12 16:23 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-04 19:06:32 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Russell Dickenson 2017-01-13 02:23:14 UTC
Description of problem: Because the "Publish New Version" button is always enabled, it is impossible for the user to know if there are saved changes waiting to be published.

How reproducible: Always

Steps to Reproduce:
1. Navigate Content > Content Views and select any content view, the "Publish New Version" button is enabled, which suggests that there have been changes made which require publishing. This 
2. Select any content view.
3. Click "Publish New Version" button, then click "Save" button.

Actual results: CV is successfully published, and "Publish New Version" button is enabled.

Expected results: CV is successfully published, and "Publish New Version" button is *NOT* enabled.

Comment 1 Brad Buckingham 2017-01-13 16:35:41 UTC
Note: when addressing this, we would need to ensure that if a content view publish fails (for any reason) that the user can still publish a new version.

Comment 3 Bryan Kearney 2018-09-04 18:56:09 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.

Comment 4 Bryan Kearney 2018-09-04 19:06:32 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.