Bug 1412876 - [RFE] Provide a method of previewing the content matching a Content View - i.e. # packages and # errata
Summary: [RFE] Provide a method of previewing the content matching a Content View - i....
Keywords:
Status: CLOSED DUPLICATE of bug 1148490
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Content Views
Version: 6.2.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-13 03:14 UTC by Russell Dickenson
Modified: 2017-10-12 13:25 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-10-12 13:25:42 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Russell Dickenson 2017-01-13 03:14:07 UTC
Description of problem: When making changes to a Content View, the user cannot know in advance how many packages and/or errata match the criteria. This is important because it provides no benefit if the criteria are incorrect. At the moment the only means of doing this is to publish the Content View and check the Content column of the table on the Content View's "Versions" tab. Using that method is inefficient because it can take several minutes for a Content View to be published. If getting a Content View's criteria correct requires a cycle of "change, save, publish, check, and repeat", that is very inefficient.

How reproducible: Always.

Steps to Reproduce:
1. Open the Satellite web UI, and navigate to Content > Content Views.
2. Make a change to a Content View's criteria, and save the changes.

Actual results: There is no means of confirming how many packages match the Content View, except for saving and publishing it.

Expected results: There is an option to "preview" the number of packages which would match the Content View's edited and saved, but not yet published, criteria.

Comment 1 Rich Jerrido 2017-10-12 13:25:42 UTC

*** This bug has been marked as a duplicate of bug 1148490 ***


Note You need to log in before you can comment on or make changes to this bug.