Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1412900 - All LVs active after iSCSI storage connection
Summary: All LVs active after iSCSI storage connection
Keywords:
Status: CLOSED DUPLICATE of bug 1331978
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 4.0.6
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: ---
Assignee: Dan Kenigsberg
QA Contact: Raz Tamir
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-13 04:47 UTC by Germano Veit Michel
Modified: 2017-01-16 01:59 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-15 09:33:27 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)

Description Germano Veit Michel 2017-01-13 04:47:14 UTC
Description of problem:

If this is going to be fixed by BZ #1374545 or not, I am pretty sure this is not desirable behavior I needed to report it.

1. Host is in Maintenance Mode or shutdown, disconnected from iSCSI storage.
2. Activate Host
3. Host connects to Storage
4. All LVs from that Storage are activated (similar to BZ #1374545)
5. VDSM doesn't deactivate them, they are all left active.

- Wouldn't it be sane to deactivate them as we do for FC on boot? https://gerrit.ovirt.org/#/c/21291/

For long version, check logs.txt attached. Here is the summary:
Jan 13 14:12:28 RHEL-H kernel: scsi 2:0:0:0: Attached scsi generic sg1 type 0
Jan 13 14:12:28 RHEL-H kernel: sd 2:0:0:0: [sda] 209715200 512-byte logical blocks: (107 GB/100 GiB)
Jan 13 14:12:28 RHEL-H kernel: sd 2:0:0:0: [sda] Attached SCSI disk
Jan 13 14:12:28 RHEL-H multipathd: sda: add path (uevent)
Jan 13 14:12:28 RHEL-H kernel: device-mapper: multipath service-time: version 0.3.0 loaded
Jan 13 14:12:28 RHEL-H multipathd: 3600140511e512ba924f4b35a18d95e15: load table [0 209715200 multipath 0 0 1 1 service-time 0 1 1 8:0 1]
Jan 13 14:12:28 RHEL-H multipathd: 3600140511e512ba924f4b35a18d95e15: event checker started
Jan 13 14:12:28 RHEL-H multipathd: sda [8:0]: path added to devmap 3600140511e512ba924f4b35a18d95e15
Jan 13 14:12:28 RHEL-H systemd: Created slice system-lvm2\x2dpvscan.slice.
Jan 13 14:12:28 RHEL-H systemd: Starting system-lvm2\x2dpvscan.slice.
Jan 13 14:12:28 RHEL-H systemd: Starting LVM2 PV scan on device 252:0...
Jan 13 14:12:29 RHEL-H lvm: 7 logical volume(s) in volume group "f3d842ef-66c3-45f8-86c2-dfd055e10c9b" now active
Jan 13 14:12:29 RHEL-H systemd: Started LVM2 PV scan on device 252:0.

Version-Release number of selected component (if applicable):
vdsm-4.18.21-1.el7ev.x86_64
kernel-3.10.0-514.2.2.el7.x86_64
lvm2-2.02.166-1.el7_3.1.x86_64



How reproducible:
100%

Steps to Reproduce:
1. Add iSCSI storage
2. Reboot Host
3. Activate Host (so it logs into iSCSI storage)

Actual results:
All LVs active

Expected results:
No LVs active

Comment 2 Yaniv Kaul 2017-01-14 16:05:22 UTC
Sounds like https://gerrit.ovirt.org/#/c/56876/ ?

Comment 3 Tal Nisan 2017-01-15 09:33:27 UTC

*** This bug has been marked as a duplicate of bug 1374545 ***

Comment 4 Germano Veit Michel 2017-01-16 01:59:56 UTC
(In reply to Yaniv Kaul from comment #2)
> Sounds like https://gerrit.ovirt.org/#/c/56876/ ?

Yup! Missed it. Sorry.

But from that gerrit this is a dup of 1331978 and not 1374545.

*** This bug has been marked as a duplicate of bug 1331978 ***


Note You need to log in before you can comment on or make changes to this bug.