Bug 1412931 - guile: FTBFS in Fedora Rawhide
Summary: guile: FTBFS in Fedora Rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: guile
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-13 07:15 UTC by Igor Gnatenko
Modified: 2017-02-13 16:05 UTC (History)
3 users (show)

Fixed In Version: guile-2.0.13-4.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-17 12:41:04 UTC
Type: Bug


Attachments (Terms of Use)

Description Igor Gnatenko 2017-01-13 07:15:17 UTC
FAIL: 00-repl-server.test: repl-server: simple expression - arguments: (expected-value "scheme@(repl-server)> $1 = 42\n" actual-value "$1 = 42\n")

not sure what caused this bug, since it fails on x86_64/aarch64, but passes on i686/armv7hl/ppc64/ppc64le.

Comment 1 Daniel Moerner 2017-01-14 18:14:01 UTC
Hi,

I wasn't able to reproduce this test failure building against readline-7 (as far as I can tell) either with a koji scratch-build (https://koji.fedoraproject.org/koji/taskinfo?taskID=17283898) or with a local x86_64 mock using a koji mock-config.

Comment 2 Miroslav Lichvar 2017-01-17 12:41:04 UTC
Whatever it was, it seems to be fixed now.

Comment 3 Miroslav Lichvar 2017-02-13 16:05:53 UTC
It actually was not fixed. I hit it on ppc64. It seems there was an upstream commit for this issue, which is now included in the rawhide package.


Note You need to log in before you can comment on or make changes to this bug.