Bug 1412935 - Can not get kernel version from reports
Summary: Can not get kernel version from reports
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Reporting
Version: 5.6.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.9.0
Assignee: Tim Wade
QA Contact: Satyajit Bulage
URL:
Whiteboard: smartstate:report
Depends On:
Blocks: 1455302 1458365
TreeView+ depends on / blocked
 
Reported: 2017-01-13 07:33 UTC by Chen
Modified: 2020-08-13 08:48 UTC (History)
11 users (show)

Fixed In Version: 5.9.0.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1455302 1458365 (view as bug list)
Environment:
Last Closed: 2018-03-06 14:48:04 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
blank kernel version report (280.64 KB, image/jpeg)
2017-01-13 07:33 UTC, Chen
no flags Details
kernel report (908 bytes, text/x-vhdl)
2017-04-28 18:04 UTC, Tim Wade
no flags Details

Description Chen 2017-01-13 07:33:43 UTC
Created attachment 1240222 [details]
blank kernel version report

Description of problem:

Can not get kernel version from reports

Version-Release number of selected component (if applicable):

5.6.3.3

How reproducible:

100%

Steps to Reproduce:
1. Enable SSA for every VM
2. Generate reports as attachments
3.

Actual results:

Kernel Version is empty

Expected results:


Additional info:

Comment 3 Dave Johnson 2017-01-19 16:24:51 UTC
This is information collected through smartstate analysis.  Satyajit, can you reproduce this and see that the report is correct when successful ssa scans have completed.

Comment 5 Chen 2017-01-24 01:39:01 UTC
Hi Dave, Satyajit,

Since we could reproduce this issue do we have any progress in fixing the problem ? Any news is welcome.

Best Regards,
Chen

Comment 6 Chen 2017-03-09 00:43:28 UTC
Hi Dave, Satyajit,

Sorry for raising the severity. Do we have any news about this bug since we can reproduce it ?

Best Regards,
Chen

Comment 21 Chen 2017-03-22 13:33:03 UTC
Hi Tim,

Thank you very much for your reply.

Your suggestion could help me to list the kernel version of each VMs but the report size is too huge... I am worrying if the customer got many VMs then their DB will explode. And for filtering part, PDF is impossible to filter and I found CSV is complex to me as well... I tried to download the report as txt file but the file can not show all the columns thus I can not filter the kernel package version..

So seems we cost too much to get only one package version. We can't achieve this(only get one package's version) using report right ?  

Best Regards,
Chen

Comment 27 Tim Wade 2017-04-28 18:04:47 UTC
Created attachment 1274987 [details]
kernel report

Comment 39 Satyajit Bulage 2017-11-09 15:40:40 UTC
Getting Kernel version with appropriate report having filter present.

Verified Version: 5.9.0.7.20171107212356_ed87902


Note You need to log in before you can comment on or make changes to this bug.