Bug 141294 - segfaults during recursive grep of /etc
segfaults during recursive grep of /etc
Status: CLOSED DUPLICATE of bug 144593
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-11-30 01:03 EST by Michael A. Peters
Modified: 2015-01-04 17:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg > dmesg.txt (15.25 KB, text/plain)
2004-11-30 04:38 EST, Michael A. Peters
no flags Details

  None (edit)
Description Michael A. Peters 2004-11-30 01:03:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
[root@devel etc]# grep -R "ttyS0" *
grep: httpd/run/dbus/system_bus_socket: No such device or address
grep: httpd/run/acpid.socket: No such device or address
mgetty+sendfax/mgetty.config:# Zoom V.FX 28.8, connected to ttyS0:
don't do fax, less logging
mgetty+sendfax/mgetty.config:#port ttyS0
sane.d/dc210.conf:port=/dev/ttyS0
sane.d/dc25.conf:port=/dev/ttyS0
sane.d/dc240.conf:port=/dev/ttyS0
grep: udev/devices/nvidia94: No such device
grep: udev/devices/nvidia85: No such device
grep: udev/devices/nvidia32: No such device
grep: udev/devices/nvidia62: No such device
grep: udev/devices/nvidia56: No such device
grep: udev/devices/nvidia141: No such device
grep: udev/devices/nvidia115: No such device
grep: udev/devices/nvidia75: No such device
grep: udev/devices/nvidia189: No such device
grep: udev/devices/nvidia108: No such device
grep: udev/devices/nvidia251: No such device
Segmentation fault
[root@devel etc]# 

Version-Release number of selected component (if applicable):
grep-2.5.1-31

How reproducible:
Sometimes

Steps to Reproduce:
1. cd /etc
2. grep -R "ttyS0" *
3.
    

Actual Results:  segfault

Expected Results:  finish my grep

Additional info:

I'm not sure what it is segfaulting on - there is some period of time
after the last grep error before it segfaults.
Comment 1 Tim Waugh 2004-11-30 03:42:44 EST
Please install grep-debuginfo-2.5.1-31 from:

  ftp://download.fedora.redhat.com/pub/fedora/linux/core/3/i386/debug/

Then run:

  cd /etc
  gdb --args grep -R "ttyS0" *
  (gdb) run

When it crashes, type: bt (and press enter).  What does it say?
Comment 2 Tim Waugh 2004-11-30 03:45:36 EST
Actually, before you do that does running 'dmesg' after the grep command show a
kernel oops? (If not continue as in comment #1)
Comment 3 Michael A. Peters 2004-11-30 04:12:20 EST
grep: udev/devices/nvidia115: No such device
grep: udev/devices/nvidia75: No such device
grep: udev/devices/nvidia189: No such device
grep: udev/devices/nvidia108: No such device
grep: udev/devices/nvidia251: No such device

Program terminated with signal SIGSEGV, Segmentation fault.
The program no longer exists.
(gdb) bt
No stack.
(gdb) 
Comment 4 Tim Waugh 2004-11-30 04:22:59 EST
And dmesg?
Comment 5 Michael A. Peters 2004-11-30 04:38:19 EST
Created attachment 107611 [details]
dmesg > dmesg.txt
Comment 6 Michael A. Peters 2004-11-30 04:40:27 EST
drivers/usb/input/hid-core.c: input irq status -71 received
drivers/usb/input/hid-core.c: input irq status -71 received
drivers/usb/input/hid-core.c: input irq status -71 received
drivers/usb/input/hid-core.c: input irq status -71 received
drivers/usb/input/hid-core.c: input irq status -71 received

Not sure what is causing those, been there like crazy since the FC3Test2 (never
ran Test1) - but they are probably unrelated
Comment 7 Tim Waugh 2004-11-30 05:03:38 EST
This is a kernel oops caused by the nvidia module:

[<13172525>] nv_alloc_file_private+0x11f/0x13a [nvidia]
Comment 8 Tim Waugh 2004-11-30 05:04:05 EST

*** This bug has been marked as a duplicate of 73733 ***
Comment 9 Michael A. Peters 2004-11-30 05:05:13 EST
Yeah - I just booted w/o nvidia and grep works.
Comment 10 Harald Hoyer 2005-01-12 04:19:53 EST

*** This bug has been marked as a duplicate of 144593 ***
Comment 11 Red Hat Bugzilla 2006-02-21 14:07:21 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.