Bug 1412951 - Blacklist kms driver to prevent kexec issues
Summary: Blacklist kms driver to prevent kexec issues
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Discovery Image
Version: 6.2.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Unspecified
Assignee: Lukas Zapletal
QA Contact: Roman Plevka
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1334477 (view as bug list)
Depends On:
Blocks: 1417109
TreeView+ depends on / blocked
 
Reported: 2017-01-13 08:49 UTC by Lukas Zapletal
Modified: 2020-05-14 15:32 UTC (History)
12 users (show)

Fixed In Version: foreman-discovery-image-3.1.1-20
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1417109 (view as bug list)
Environment:
Last Closed: 2017-03-06 08:37:01 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 15144 0 'Normal' 'Closed' 'Blacklist kms driver to prevent kexec issues' 2019-11-27 14:26:16 UTC
Red Hat Bugzilla 1334477 1 None None None 2021-01-20 06:05:38 UTC
Red Hat Knowledge Base (Solution) 2303391 0 None None None 2019-10-10 12:04:50 UTC
Red Hat Product Errata RHBA-2017:0447 0 normal SHIPPED_LIVE Satellite 6.2.8 Async Bug Release 2017-03-06 13:23:41 UTC

Internal Links: 1334477

Description Lukas Zapletal 2017-01-13 08:49:51 UTC
We found an issue in kexec when terminal is frozen due to graphics driver stack, this is a request to backport two lines into FDI for 6.2 to prevent these errors. We have seen this multiple times already, some cases were attached to 6.3 bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1334477

We've seen this with both virtualized and bare-metal environments.

*HIGH IMPACT*, *LOW RISK*, *LOW EFFORT*.

Comment 2 pm-sat@redhat.com 2017-01-13 11:17:15 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/15144 has been resolved.

Comment 4 Lukas Zapletal 2017-02-20 13:52:34 UTC
Verification steps:

Verify that DRI drivers are not present on the FDI image:

rm -rf /lib/modules/*/kernel/drivers/gpu/drm /lib/firmware/{amdgpu,radeon}

Extra verification:

KExec VM in all possible QEMU video drivers (QXL, Cirrus, KVM): http://libvirt.org/formatdomain.html#elementsVideo and all should work fine.

Comment 5 Roman Plevka 2017-02-22 16:38:09 UTC
I was unable to replicate the issue on sat6.2.7 (foreman-discovery-image-3.1.1-16.iso).

I've created generic hosts where each used a different driver:
-cirrus
-qxl
-vga

(the other 3 options - virtio, vmvga and xen were not working for me at all - vmvga+xen gave me the blank screen)

I booted up FDI, sent the facts out to the satellite and then provisioned them from satellite.
All console sessions made it through the kexec phase just fine.

Comment 6 Lukas Zapletal 2017-02-23 08:35:13 UTC
*** Bug 1334477 has been marked as a duplicate of this bug. ***

Comment 7 Roman Plevka 2017-02-23 12:17:09 UTC
VERIFIED
sat6.2.8 snap#3
foreman-discovery-image-3.1.1-20.iso

Comment 9 errata-xmlrpc 2017-03-06 08:37:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:0447

Comment 13 Lukas Zapletal 2017-03-23 10:05:57 UTC
QA NOTES:

Boot the image and verify these does NOT exist:

/lib/modules/*/kernel/drivers/gpu/drm /lib/firmware/{amdgpu,radeon}

Comment 21 Roman Plevka 2017-04-20 08:08:46 UTC
verified for snap3
(both rhel6 and rhel7 repos now contain -22 version of FDI package)

Comment 22 Bryan Kearney 2017-05-01 14:29:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1191

Comment 23 Bryan Kearney 2017-05-01 14:29:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1191


Note You need to log in before you can comment on or make changes to this bug.