Bug 141300 - internal compiler error, Segmentation Fault
Summary: internal compiler error, Segmentation Fault
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc   
(Show other bugs)
Version: 3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-11-30 07:40 UTC by Eric Varsanyi
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-01 15:18:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Preprocessed source of program causing fault (132.41 KB, application/octet-stream)
2004-11-30 07:43 UTC, Eric Varsanyi
no flags Details
patch that fixes the bug, back-ported to the gcc-3_4-rhl branch (2.64 KB, patch)
2004-12-09 12:37 UTC, Alexandre Oliva
no flags Details | Diff

Description Eric Varsanyi 2004-11-30 07:40:03 UTC
<TARA> anya /wrkl/ev/tara/obj/scTest$ make
Bld [StatementCache]          ../../src/StatementCache/ImportRequest.cc
../../src/StatementCache/ImportRequest.cc: In member function `void
StatementCache::ImportRequest::completeRequest(GENPTR) [with GENPTR =
LangCore::QueryPtr, STYPE = StatementCache::Query]':
../../src/StatementCache/ImportRequest.cc:51:   instantiated from here
../../src/StatementCache/ImportRequest.cc:42: internal compiler error:
Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
Preprocessed source stored into /tmp/ccbOjhTL.out file, please attach
this to your bugreport.



Version-Release number of selected component (if applicable):
gcc-3.4.2-6.fc3

How reproducible:
Always

Steps to Reproduce:
1. compile attached file with said compiler
2.
3.
    

Actual Results:  Error message, segmentation fault

Expected Results:  .o generated

Additional info:

Comment 1 Eric Varsanyi 2004-11-30 07:43:11 UTC
Created attachment 107606 [details]
Preprocessed source of program causing fault

Compressed it because it was over 1M.

Comment 2 Eric Varsanyi 2004-11-30 07:47:26 UTC
There are likely errors in the input file beyond the segfault problem,
this is the first time I've tried compiling this module.

Comment 3 Jakub Jelinek 2004-12-01 15:18:33 UTC
This is ICE on invalid (i.e. low priority), therefore I filed this upstream
(it is reproduceable with several GCC versions).
http://gcc.gnu.org/PR18757

Comment 4 Alexandre Oliva 2004-12-09 12:37:44 UTC
Created attachment 108197 [details]
patch that fixes the bug, back-ported to the gcc-3_4-rhl branch


Note You need to log in before you can comment on or make changes to this bug.